Reply
Member
HyperXAI123
Posts: 3
Registered: ‎08-17-2012
Accepted Solution

E00027 2,1,2,This transaction has been declined

[ Edited ]

Works fine on the testMode but does not want to work on liveMode. Help, plz, what's the problem?

 

Request:

<?xml version="1.0" encoding="utf-8"?>
<createCustomerProfileRequest xmlns="AnetApi/xml/v1/schema/AnetApiSchema.xsd">
    <merchantAuthentication>
    <name>**</name>
    <transactionKey>**</transactionKey>
    </merchantAuthentication>
    <profile>
    <merchantCustomerId>111111</merchantCustomerId>
    <email>32672683@mail.ru</email>
    <paymentProfiles>
        <billTo>
        <firstName>Sergey</firstName>
        <lastName>Miroshnikov</lastName>
        <company>home</company>
        <address>aaaaa aaa</address>
        <city>New York</city>
        <zip>1111</zip>
        <country>United States</country>
        <phoneNumber>000-00-00</phoneNumber>
        </billTo>
        <payment>
        <creditCard>
            <cardNumber>************5919</cardNumber>
            <expirationDate>2013-11</expirationDate>
            <cardCode>***</cardCode>
        </creditCard>
        </payment>
    </paymentProfiles>
    </profile>
    <validationMode>liveMode</validationMode>
</createCustomerProfileRequest>

 

 

Answer:

object(SimpleXMLElement)#198 (4) {
  ["messages"]=>
  object(SimpleXMLElement)#200 (2) {
    ["resultCode"]=>
    string(5) "Error"
    ["message"]=>
    object(SimpleXMLElement)#202 (2) {
      ["code"]=>
      string(6) "E00027"
      ["text"]=>
      string(35) "This transaction has been declined."
    }
  }
  ["customerPaymentProfileIdList"]=>
  object(SimpleXMLElement)#177 (0) {
  }
  ["customerShippingAddressIdList"]=>
  object(SimpleXMLElement)#199 (0) {
  }
  ["validationDirectResponseList"]=>
  object(SimpleXMLElement)#201 (1) {
    ["string"]=>
    string(383) "2,1,2,This transaction has been declined.,,S,4604666363,none,Test transaction for ValidateCustomerPaymentProfile.,0.00,CC,auth_only,11111111111111111-4,Sergey,Miroshnikov,home,aaaaaaaa,New York,,1111,United States,000-00-00,,32672683@mail.ru,none,none,none,none,none,none,none,none,0.00,0.00,0.00,FALSE,none,B4BC638117B0355279326AB214CDC2CD,P,,,,,,,,,,,,XXXX5919,Visa,,,,,,,,,,,,,,,,"
  }
}

 

Expert
RaynorC1emen7
Posts: 3,653
Registered: ‎03-08-2010

Re: E00027 2,1,2,This transaction has been declined

It this a production account? Do you have the AVS settings on and what it is?

Member
HyperXAI123
Posts: 3
Registered: ‎08-17-2012

Re: E00027 2,1,2,This transaction has been declined

Yes, it`s a product account, but I don`t have access to it. What should I put in AVS settings?

Expert
RaynorC1emen7
Posts: 3,653
Registered: ‎03-08-2010

Re: E00027 2,1,2,This transaction has been declined

2,1,2 I think it decline by the customer CC issuing bank. Probably will need to contact authorize.net and give them the transactionID and see if there is more detail on why it is decline.

Member
HyperXAI123
Posts: 3
Registered: ‎08-17-2012

Re: E00027 2,1,2,This transaction has been declined

[ Edited ]