Reply
Contributor
Posts: 14
Registered: ‎03-26-2013

AIM Refund XML Posts Fine, But Doesn't Show Up in Reports on Test Account

I'm coding in PHP, working with the AIM Refund XML, with a sample here:

 

http://pastie.org/7129488

 

(Above, the $sOTC stands for the AuthNet trans id, and means Order Transaction Code in my PHP app.)

 

This works against a settled transaction and emits a responseCode of 1 with description "This transaction has been approved.". However, when I go into test.authorize.net to check this out, the very same transaction STILL lets me do a refund on it, even though supposedly I have done one, and I see that nothing has come in since the 19th, even though today is the 26th.

 

What am I doing wrong?

 

Contributor
Posts: 14
Registered: ‎03-26-2013

Re: AIM Refund XML Posts Fine, But Doesn't Show Up in Reports on Test Account

BTW, I try it again and it now responds with "The sum of credits against the referenced transaction would exceed original debit amount." So, that tells me that it is doing SOMETHING against test.authorize.net, but why I can't view this in the interface under Reports is beyond me. I mean, this is exactly the response one should see if they've already refunded the account enough times.

 

Me thinks test.authorize.net is broke.

Contributor
Posts: 14
Registered: ‎03-26-2013

Re: AIM Refund XML Posts Fine, But Doesn't Show Up in Reports on Test Account

Is the system down? Why are refund transactions not showing up, but they return back all the proper status information?

 

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: AIM Refund XML Posts Fine, But Doesn't Show Up in Reports on Test Account

Does refund XML post return a transactionID?

Contributor
Posts: 14
Registered: ‎03-26-2013

Re: AIM Refund XML Posts Fine, But Doesn't Show Up in Reports on Test Account

Yes, I receive a transID value and refTransID, and they are not zero.

 

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: AIM Refund XML Posts Fine, But Doesn't Show Up in Reports on Test Account

and it is not showing on the unsettled transaction?

Contributor
Posts: 14
Registered: ‎03-26-2013

Re: AIM Refund XML Posts Fine, But Doesn't Show Up in Reports on Test Account

I click Reports > Item Type says only Settled and Declined. It also lists the 19th as the last date, not today. I can't even choose today. I then click Run Report and I see the record I'm working against. I click it and the window pops open and shows a Refund button. I click it and it says that the account has already been refunded.

 

That looks like a sandbox bug to me.

 

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: AIM Refund XML Posts Fine, But Doesn't Show Up in Reports on Test Account

on the top click search

on the Settlement Date change from or to to unsettled

click the button

Contributor
Posts: 14
Registered: ‎03-26-2013

Re: AIM Refund XML Posts Fine, But Doesn't Show Up in Reports on Test Account

Ah, I now see these following. I see in the report:

 

2186542107
Refund/Pending Settlement
26-Mar-2013 12:27:13 Doe, John
D
XXXX0012
USD 39.94

 


2186523302
Captured/Pending Settlement
26-Mar-2013 09:10:18 Doe, John
D
XXXX0012
USD 39.94