Reply
Member
Posts: 5
Registered: ‎03-04-2014

ARB issue

All teh sudden there is a issue happening. When i do the ARB create account. For the responce from api i get the following.

 

HTTP/1.1 403 Forbidden Content-Type: text/html Server: Microsoft-IIS/7.5 X-Powered-By: ASP.NET Date: Thu, 10 Jul 2014 16:21:35 GMT Content-Length: 58 You do not have permission to view this directory or page.

 

Any help would be appriciatred

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: ARB issue

What the URL you are try to send the ARB to?

Member
Posts: 5
Registered: ‎03-04-2014

Re: ARB issue

$host = "api.authorize.net/xml/v1/request.apit";
$path = "/xml/v1/request.api";

Member
Posts: 5
Registered: ‎03-04-2014

Re: ARB issue

Heres the thing. As of the 8th all was working just fine. People could joina nd subscriptions woudl get set up fine. Then on the 9th this started happening. Nothing has changed in my code and has been working just fine for the last 7 months. I have called Authorize.net and they say there is nothing going wrong on there end.

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: ARB issue

"api.authorize.net/xml/v1/request.apit";

 

there no t for api 

Member
Posts: 5
Registered: ‎03-04-2014

Re: ARB issue

ty i dug into the code and found the right url. this was never changed so kind or wierd it worked for the last 6 months then broke yesterday. any ways i have fixed it. thanks for your help. i verified that url with there support and they told me it was right. glad they could help. :) i think you know more about there system then they do.

Member
Posts: 4
Registered: ‎07-15-2014

Re: ARB issue

I am getting a similar problem.

The ARB was working and then I went to test it again and all of the sudden it is not.

On the same php script I do a single transaction and it works with same credentials but ARB does not.

Here is the ARB part of my code:

 

$host = "api.authorize.net/xml/v1/request.api";
$path = "/xml/v1/request.api";

 

 

 

$content =
"<?xml version=\"1.0\" encoding=\"utf-8\"?>" .
"<ARBCreateSubscriptionRequest xmlns=\"AnetApi/xml/v1/schema/AnetApiSchema.xsd\">" .
"<merchantAuthentication>".
"<name>" . $login . "</name>".
"<transactionKey>" . $tran_key . "</transactionKey>".
"</merchantAuthentication>".
"<refId>" . $refId . "</refId>".
"<subscription>".
"<name>" . $name . "</name>".
"<paymentSchedule>".
"<interval>".
"<length>". $length ."</length>".
"<unit>". $unit ."</unit>".
"</interval>".
"<startDate>" . $startDate . "</startDate>".
"<totalOccurrences>". $totalOccurrences . "</totalOccurrences>".
"<trialOccurrences>". $trialOccurrences . "</trialOccurrences>".
"</paymentSchedule>".
"<amount>". $amount ."</amount>".
"<trialAmount>" . 0 . "</trialAmount>". ///Charged above in the other transaction
"<payment>".
"<creditCard>".
"<cardNumber>" . $cardNumber . "</cardNumber>".
"<expirationDate>" . $expirationDate . "</expirationDate>".
"</creditCard>".
"</payment>".
"<order>".
"<invoiceNumber>" . $clientid . "</invoiceNumber>".
"<description>" . $name . "</description>".
"</order>".
"<billTo>".
"<firstName>". $firstName . "</firstName>".
"<lastName>" . $lastName . "</lastName>".
"</billTo>".
"</subscription>".
"</ARBCreateSubscriptionRequest>";


//send the xml via curl
$response = send_request_via_curl($host,$path,$content);

 

 

 

//function to send xml request via curl
function send_request_via_curl($host,$path,$content)
{
$posturl = "https://" . $host . $path;
$ch = curl_init();
curl_setopt($ch, CURLOPT_URL, $posturl);
curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
curl_setopt($ch, CURLOPT_HTTPHEADER, Array("Content-Type: text/xml"));
curl_setopt($ch, CURLOPT_HEADER, 1);
curl_setopt($ch, CURLOPT_POSTFIELDS, $content);
curl_setopt($ch, CURLOPT_POST, 1);
curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, 0);
$response = curl_exec($ch);
return $response;
}

 

Any help would be appreciated.

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: ARB issue

error? what is the response?

Member
Posts: 4
Registered: ‎07-15-2014

Re: ARB issue

The same:

HTTP/1.1 403 Forbidden Content-Type: text/html Server: Microsoft-IIS/7.5 X-Powered-By: ASP.NET Date: Tue, 15 Jul 2014 15:55:54 GMT Content-Length: 58 You do not have permission to view this directory or page.

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: ARB issue

can you echo $posturl

in the function send_request_via_curl($host,$path,$content)