Reply
Member
Posts: 4
Registered: ‎04-10-2019

Accept Hosted with Hosted Form throwing E_WC_21 error in live mode

I'm having an issue I can't seem to figure out. Getting a "E_WC_21: User authentication failed due to invalid authentication values" while in Live mode. I get the hosted form pop up, enter CC info, hit submit but then get the error. It works perfectly fine in sandbox enviro.

 

- I know my API Login ID is correct and Public Client Key is also correct. In fact, I recreated the client key just to make sure but still throwing error.

- I know I'm using Live Login ID & Client Key and not sandbox ones

- I've recreated client key just to make sure it's not the issue.... and it isn't

- I made sure I'm loading the proper JS resource (js.authorize.net/v3/AcceptUI.js)

 

I've essentially taken the exact sample codes from docs...

 

<div type=\"button\" class=\"AcceptUI payByAcceptHostedSubmit\" data-progress=\"0\" data-default=\"Click Here to Pay by Credit Card\"
data-billingAddressOptions='{\"show\":true, \"required\":false}'
data-apiLoginID=\"{$apiLoginID}\"
data-clientKey=\"{$apiClientKey}\"
data-acceptUIFormBtnTxt=\"Continue\"
data-acceptUIFormHeaderTxt=\"Secured Payment Information\"
data-responseHandler=\"AuthnetAcceptHostedResponseHandler\">
Click Here to Enter Credit Card Details
</div>
<img class=\"authnetAcceptHostedCCEnteredIcon\" src=\"images/icon_checkmark_1.png\">

 

<script type="text/javascript" src="https://js.authorize.net/v3/AcceptUI.js" charset="utf-8"></script>

 

Been stuck on this for 2 days now. Can anyone provide a suggestion please?