Reply
Member
Posts: 2
Registered: ‎06-19-2012
Accepted Solution

Auth Only not working with SIM

Dear All,

 


I have used x_type as AUTH_ONLY for my transaction,  but in my account that transaction type shows this text "Authorization w/ Auto capture".

Does the transaction type is correct ? My client is saying that transaction type field should display "Auth Only" not "Authorization w/ Auto capture"

 

My form:

 

    <form id="payment" method='post' action="https://secure.authorize.net/gateway/transact.dll">
    <input type='hidden' name="x_login" value="{{ api_login_id }}" />
    <input type='hidden' name="x_fp_hash" value="{{ fingerprint }}" />
    <input type='hidden' name="x_amount" value="{{ amount }}" />
    <input type='hidden' name="x_fp_timestamp" value="{{ fp_timestamp }}" />
    <input type='hidden' name="x_fp_sequence" value="{{ fp_sequence }}" />
    <input type='hidden' name="x_version" value="3.1">
    <input type='hidden' name="x_show_form" value="payment_form">
    <input type='hidden' name="x_test_request" value="false" />
    <input type='hidden' name="x_method" value="cc">
    <input type='hidden' name=”x_type” value=”AUTH_ONLY”>
    <input type='hidden' name="x_description" value="CTUSA Deposit">
    </form>

 

I got in the response e-mail:

 

============== RESULTS ==============
Response : This transaction has been approved.
Authorization Code : 063418
Transaction ID : 4455019009
Address Verification : Street Address: Match -- First 5 Digits of Zip: Match


==== CUSTOMER BILLING INFORMATION ===

==== CUSTOMER SHIPPING INFORMATION ===
First Name :
Last Name :
Company :
Address :
City :
State/Province :
Zip/Postal Code :
Country :

======= ADDITIONAL INFORMATION ======
Tax :
Duty :
Freight :
Tax Exempt :
PO Number :

========== MERCHANT DEFINED =========

"x_type" : "AUTH_ONLY"

 

Thank you for the assistance,

Alexander


Accepted Solutions
Solution
Accepted by topic author alexlush
‎08-21-2015 01:58 AM
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Auth Only not working with SIM

Not sure if it make a different but the double quote on

<input type='hidden' name=”x_type” value=”AUTH_ONLY”>

 is not like any other, it hex code 94 instead of hex code 22

 

http://ascii-code.com/

View solution in original post


All Replies
Solution
Accepted by topic author alexlush
‎08-21-2015 01:58 AM
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Auth Only not working with SIM

Not sure if it make a different but the double quote on

<input type='hidden' name=”x_type” value=”AUTH_ONLY”>

 is not like any other, it hex code 94 instead of hex code 22

 

http://ascii-code.com/

Member
Posts: 2
Registered: ‎06-19-2012

Re: Auth Only not working with SIM

Thank you!

 

Yes, it was the problem with a cute-and-paste :)