Reply
Highlighted
Member
Posts: 8
Registered: ‎01-04-2012

Re: Authorize.net DPM blank screen on post

Hi TJ-

 

Was actually just testing with AIM...  I think I like how that works much better.

Their sample was more of what I am looking for.

 

I'm taking this over and have very little knowledge of how to integrate either.

Is it as simple as changing the method (declaring AIM vs DPM)...?

The samples was just a switch in settings. 

 

Thanks again - appreciate the insight.

 

--Jeff

 

Highlighted
Solution
Accepted by topic author HDLLC
‎08-21-2015 01:58 AM
Posts: 1,609
Topics: 15
Kudos: 201
Solutions: 121
Registered: ‎06-23-2011

Re: Authorize.net DPM blank screen on post

AIM is the simplest API to integrate. Assuming you're using PHP, you can get excellent examples of how to use it by looking in the doc folder of your SDK for a file called AIM.markdown.

Highlighted
Member
Posts: 8
Registered: ‎01-04-2012

Re: Authorize.net DPM blank screen on post

10-4 - thanks a ton, TJ!

Much appreciated!

Highlighted
Member
Posts: 3
Registered: ‎01-30-2012

Re: Authorize.net DPM blank screen on post

I'm having the same issue, but it's only periodically, when my server is under a lot of load.

 

We are in the process of getting a new, more powerfull server.  But, it would be nice if there was a message for the customer, rather than just a blank screen.

 

"Please wait while we process your order." or something like that.

 

Dan

 

Highlighted
Member
Posts: 3
Registered: ‎01-30-2012

Re: Authorize.net DPM blank screen on post

[ Edited ]

It looks like my previous post may be incorrect.  I have talked to a couple customers that said that the "blank page" remained on their browsers for a few minutes.  When I look at my logs, I see that my site responded with the redirect within a couple of seconds.

 

Has anyone else had this issue?  It seems to only have happened to a handful of our users, but it is still troubling.  The transaction goes through at Authorize.net, but the order is never finalized on our site.  

 

Are there any browser settings that may be stopping the redirect?

 

Thanks - 

Dan Bergan

Highlighted
Posts: 1,609
Topics: 15
Kudos: 201
Solutions: 121
Registered: ‎06-23-2011

Re: Authorize.net DPM blank screen on post

It's possible your nameserver is slow, in which case every time Authorize.net tries to look up your domain, it takes more than the required amount of time. How frequently that happens would depend on your DNS refresh rate.

 

It's also possible your site was lagging too badly during those particular periods. What kind of hosting do you have?

Highlighted
Member
Posts: 3
Registered: ‎01-30-2012

Re: Authorize.net DPM blank screen on post

Our DNS is hosted by Rackspace.  We have a dedicated server -- however, we are in the processing of upgrading to a newer, more powerful server.

 

This does seem to happen slightly more often when our server is busy, but in this case, I can see in the logs that my server responded to the Authorize.net callback within one second.  However, the customer said that screen remained blank for a couple of minutes before he used the back button and resubmitted the payment.

 

 

Highlighted
Posts: 1,609
Topics: 15
Kudos: 201
Solutions: 121
Registered: ‎06-23-2011

Re: Authorize.net DPM blank screen on post

If the response time is more than a few seconds, Authorize.net will sever the connection, meaning they could sit there for an infinite amount of time and still get the blank screen. A few seconds is a LONG time in computing terms, though.