Reply
Highlighted
Member
Posts: 8
Registered: ‎01-04-2012
Accepted Solution

Authorize.net DPM blank screen on post

Is there anything I can do to eliminate a blank screen when I post the order to: https://secure.authorize.net/gateway/transact.dll

 

???

 

It goes from my site, to blank white screen at that address, then back to my result page.  Problem occurs when connection is slow, it stays white screen for a while.  Getting customer complaint calls.

 

Perhaps I'm handling something wrong?

 

Thanks in advance!

 

--Jeff


Accepted Solutions
Highlighted
Solution
Accepted by topic author HDLLC
‎08-21-2015 01:58 AM
Posts: 1,609
Topics: 15
Kudos: 201
Solutions: 121
Registered: ‎06-23-2011

Re: Authorize.net DPM blank screen on post

AIM is the simplest API to integrate. Assuming you're using PHP, you can get excellent examples of how to use it by looking in the doc folder of your SDK for a file called AIM.markdown.

View solution in original post


All Replies
Highlighted
Posts: 1,476
Topics: 33
Kudos: 34
Solutions: 126
Registered: ‎09-14-2009

Re: Authorize.net DPM blank screen on post

Does this happen consistently? Does it happen when posting to Authorize.Net? Or when returning from Authorize.Net? Can you duplicate it when using their development server?


-------------------------------------------------------------------------------------------------------------------------------------------
John Conde :: Certified Authorize.Net Developer (Brainyminds) :: Official Authorize.Net Blogger

NEW! Handling Authorize.Net's Webhooks with PHP

Integrate Every Authorize.Net JSON API with One PHP Class (Sample code included)

Tutorials for integrating Authorize.Net with PHP: AIM, ARB, CIM, Silent Post
All About Authorize.Net's Silent Post
Highlighted
Member
Posts: 8
Registered: ‎01-04-2012

Re: Authorize.net DPM blank screen on post

It's happening with every submit...  If you have a fast connection - it flashes white for a quick second, then back to my result screen.  If slow connection, it's multiplied (time spent on white Anet screen).

Highlighted
Posts: 1,609
Topics: 15
Kudos: 201
Solutions: 121
Registered: ‎06-23-2011

Re: Authorize.net DPM blank screen on post

What happens is the customer is submitted to a page on Authorize.net, then Authorize.net contacts a page on your server, that page determines if the transaction was successful or not, then a snippet of Javascript is sent back to forward the customer to the receipt page. So if the connection between Authorize.net and the page on your server is slow, or if it takes a while for the customer to load your receipt page, they're going to sit there for a bit staring at a white screen. How is your hosting in general? Does it always respond instantly? If not, then that's one thing you can fix. If it does, then you could try increasing the refresh time on your DNS from the usual 1 hour to something much larger, like 7 days, and see if that helps. But there may stil be a few customers on connections with really lousy nameservers that lag while ordering. The default nameserver for my Southwestern Bell DSL lagged horribly starting back some months ago, I finally figured out that I could switch to the nameserver from a different city, and apparently the one I went with isn't as overloaded, since I haven't had the problem since. But if I were still using that, I'd get 5-10 seconds of lag loading the Authorize.net page, then maybe another 5-10 seconds loading the receipt page if it's on a different domain from the order form.

Highlighted
Member
Posts: 8
Registered: ‎01-04-2012

Re: Authorize.net DPM blank screen on post

Thanks TJ - I think that is what is happening now that you mention it...

 

The site is on Network Solutions - and I've had a few projects running on them - and performance has been terrible to horrible.  I'm going to watch and see if this persists...  It wasn't this way last night - or even this morning.

And, with no code or site changes at all in last 24 hours - this just popped-up in the last hour.

 

 

Frustrating...

 

=^)

 

Thanks for the help! - I'll see what happens.

Highlighted
Posts: 1,609
Topics: 15
Kudos: 201
Solutions: 121
Registered: ‎06-23-2011

Re: Authorize.net DPM blank screen on post

The single best way to lose traffic is to have a site that lags. My guess is you're on shared hosting, probably cheap stuff, and if you have several sites you should really switch to virtual dedicated. At Network Solutions, that costs $40/mo, and at Godaddy, something like $30. I can't say as I really like Godaddy for their shared hosting, but I've used their virtual dedicated servers and those work just fine.

Highlighted
Member
Posts: 8
Registered: ‎01-04-2012

Re: Authorize.net DPM blank screen on post

Hi TJ-

 

Well - it's not my choice.  I do run a larger block of virtual dedicated and I'm really happy with it.

Needless to say - it's not with NetSol.  This customer, and a couple of others, insisted that they had to have it.

I went into it with the disclaimer that the speed sucks as does their customer service.

To no avail - here we are, fighting it.  All three have issues - but this one is enough that if I can get a test site up on my other hosting now, and show the lag on netsol - they'll move by end of day.


Thanks again!

 

--Jeff

Highlighted
Member
Posts: 8
Registered: ‎01-04-2012

Re: Authorize.net DPM blank screen on post

Well - I'm thinking this is something else (after I've finger pointed to hosting).

I ran a fresh install of everything, imported DB, set it all up on another server.  Getting same issue.

Is it supposed to actually direct to the authorize.net page and then bounce back?

I was under the impression it all happened "behind the scenes"...?


Thanks in advance!

 

--Jeff

 

 

Highlighted
Member
Posts: 8
Registered: ‎01-04-2012

Re: Authorize.net DPM blank screen on post

Okay - so, my biggest question is:

 

Is there supposed to be a blank white screen appear when the request is sent to authorize.net for processing?

Need to know whether I'm fighting something that can't be fixed... (and is supposed to work this way)

 

Thanks much!

 

--Jeff

Highlighted
Posts: 1,609
Topics: 15
Kudos: 201
Solutions: 121
Registered: ‎06-23-2011

Re: Authorize.net DPM blank screen on post

The form submits to Authorize.net. That page is not supposed to display anything, it just contacts your site back and asks for a piece of Javascript to use in forwarding customers to either a receipt or error page. Until that piece of Javascript arrives, you're stuck in the white screen. As I said before, if your receipt page is on a different domain from the one your order form is on, or if they've sat on the order page for a while and hit the refresh time, then their ISP's nameserver will need to look up the DNS, and if the nameserver happens to be lagged, that may take some seconds. If relay response page's hosting lags and the Javascript takes longer than normal to arrive, same problem.

 

You could always give up and use AIM. No back and forth, just a single internal call to Authorize.net and the customer never leaves your site.