Reply
Highlighted
Contributor
Posts: 10
Registered: ‎11-24-2015
Accepted Solution

Authorize.net Payment Not Going Through - Woocommerce 2.4.10

Prior to launching https://gsgelato.com, the site was in development - during development a payment was tested and the order was successful. Since launching the site by pointing nameservers, the payments have stopped going through to Authorize.net. I have reset transaction keys and placed multiple test orders. I've contacted Auth.net to see if there's an error on there end and they do not see one and believe the payment should be successful. I have a relay response set (the payment still does not go through when this page is set to a thank you page). What other solutions are available to make sure these payments go through to Auth.net.

 

The Woocommerce plugin I am using is Authorize.Net DPM.


Accepted Solutions
Highlighted
Solution
Accepted by topic author revivemedia
‎11-30-2015 07:42 AM
Posts: 321
Topics: 5
Kudos: 36
Blog Posts: 5
Ideas: 0
Solutions: 26
Registered: ‎11-09-2011

Re: Authorize.net Payment Not Going Through - Woocommerce 2.4.10

@revivemedia Whether you need Relay Response depends on whether your site uses the SIM/DPM methods (rather than the AIM method, which doesn't use Relay Response). It might be worth contacting Woo Commerce to determine which method they implemented.

That said, it wouldn't hurt to remove the Relay URL from your account. It's entirely possible there is some error occurring that isn't being displayed by Woo Commerce. The error may even have something to do with the Relay URL itself.

--
"Move fast and break things," out. "Move carefully and fix what you break," in.

View solution in original post


All Replies
Highlighted
Posts: 2,765
Topics: 57
Kudos: 245
Blog Posts: 67
Registered: ‎12-05-2011

Re: Authorize.net Payment Not Going Through - Woocommerce 2.4.10

 Hello @revivemedia

 

When the payment does not go through, is there an error message displayed and can you share that with us?  We may also need your server IP address as well.  You can use the contact us form if you prefer not to post publicly.

 

Richard

Highlighted
Contributor
Posts: 10
Registered: ‎11-24-2015

Re: Authorize.net Payment Not Going Through - Woocommerce 2.4.10

[ Edited ]

@RichardH

 

There isn't an error message that appears. :\ When on the phone with Auth.net, he said he wasn't getting an error and if there's an error, I should be getting a 13 or something and I'm not.

Highlighted
Posts: 2,765
Topics: 57
Kudos: 245
Blog Posts: 67
Registered: ‎12-05-2011

Re: Authorize.net Payment Not Going Through - Woocommerce 2.4.10

Have you been in touch with the Woocommerce or the plugin developer you are using?  Perhaps they can help provide better information to help you further.

 

Richard

Highlighted
Contributor
Posts: 10
Registered: ‎11-24-2015

Re: Authorize.net Payment Not Going Through - Woocommerce 2.4.10

@RichardH

 

I have a support ticket open with them as well.

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Authorize.net Payment Not Going Through - Woocommerce 2.4.10

Error 13 The merchant Login ID is invalid or the account is inactive.  

http://developer.authorize.net/api/reference/responseCodes.html?code=13

 

are you sure it using the production url?

Highlighted
Administrator Administrator
Administrator
Posts: 563
Registered: ‎08-03-2011

Re: Authorize.net Payment Not Going Through - Woocommerce 2.4.10

 

Hi revivemedia,


We can't even begin to guess at what is happening here without knowing what the user is experiencing when this occurs. Even with that, it will be difficult or impossible to give any clear advice without knowing the response being returned from Authorize.Net.

 

Thanks,

Joy

Highlighted
Contributor
Posts: 10
Registered: ‎11-24-2015

Re: Authorize.net Payment Not Going Through - Woocommerce 2.4.10

@Joy

 

Once the customer fills out their card information, this is the screen they are sent to, which is my relay response page.

 

http://i.imgur.com/zexfUXF.png

Highlighted
Contributor
Posts: 10
Registered: ‎11-24-2015

Re: Authorize.net Payment Not Going Through - Woocommerce 2.4.10

@RaynorC1emen7

 

 

Prior to launch, a payment went through. After the launch, no changes to the plugin were made for payment. I'm not sure why a payment would go through prior to changing nameservers but since it was launch the payments are no longer being sent to Auth.net.

Highlighted
Posts: 321
Topics: 5
Kudos: 36
Blog Posts: 5
Ideas: 0
Solutions: 26
Registered: ‎11-09-2011

Re: Authorize.net Payment Not Going Through - Woocommerce 2.4.10

Since this occurs after changing nameservers, could you access the web server and perform a dig or nslookup on the domain you're attempting to connect to, please?

I'm presuming you're still connecting to test.authorize.net since you didn't indicate switching to secure.authorize.net or secure2.authorize.net for live processing.

--
"Move fast and break things," out. "Move carefully and fix what you break," in.