Reply
Member
Posts: 1
Registered: ‎10-02-2015

Basic Installation Problem

Hi, I'm having some trouble with the basic installation.

 

Using the PHP example here - http://developer.authorize.net/hello_world/

I have downloaded the SDK folder from the above link and created a php file with the provided code. However, there are jms libraries not listed

"Fatal error: Class 'JMS\Serializer\SerializerBuilder' not found in /.../sdk-php-master/lib/net/authorize/api/controller/base/ApiOperationBase.php on line 74



Do you provide additional support or clarification on what libraries I need to make your code fully functional?

 

Kind regards

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Basic Installation Problem

Administrator
Posts: 149
Registered: ‎03-28-2014

Re: Basic Installation Problem

There is a dependency missing from the composer.json example it should be same as sample code file at https://github.com/AuthorizeNet/sample-code-php/blob/master/composer.json  

 

{

"require": {
"php": ">=5.2.0",
"ext-curl": "*",
"authorizenet/authorizenet": "1.8.4",
"jms/serializer": "xsd2php-dev as 0.18.0"
},
"require-dev": {
"goetas/xsd2php": "2.*@dev",
"goetas/xsd-reader": "2.*@dev"
},
"repositories": [{
"type": "vcs",
"url": "https://github.com/goetas/serializer.git"
}]

}

Member
Posts: 1
Registered: ‎01-17-2017

ailsRe: Basic Installation Problem

fails:

 

Problem 1
- Installation request for goetas/xsd-reader 2.*@dev -> satisfiable by goetas/xsd-reader[2.0.x-dev].
- goetas/xsd-reader 2.0.x-dev requires php >=5.4.0 -> your PHP version (5.3.3) does not satisfy that requirement.
Problem 2
- goetas/xsd2php 2.1.x-dev requires php >=5.5 -> your PHP version (5.3.3) does not satisfy that requirement.
- goetas/xsd2php 2.1.0 requires php >=5.5 -> your PHP version (5.3.3) does not satisfy that requirement.
- goetas/xsd2php 2.0.0-alpha requires php ~5.4 -> your PHP version (5.3.3) does not satisfy that requirement.
- goetas/xsd2php 2.0.0 requires php >=5.5 -> your PHP version (5.3.3) does not satisfy that requirement.
- Installation request for goetas/xsd2php 2.*@dev -> satisfiable by goetas/xsd2php[2.0.0, 2.0.0-alpha, 2.1.0, 2.1.x-dev].