Reply
Regular Contributor
Posts: 64
Registered: ‎10-03-2013
Accepted Solution

Batch Statistics not returned by the GetSettledBatchList in the Test Environment

I have a batch that was settled yesterday morning (Dec. 17, 2014). I use GetSettledBatchList method, passing Dec. 16th as start date for the search interval, Dec. 18th as end date for the search interval and true to indicate I want the statistics. I do get my batch (it's the only one settled in the specified time interval) but it comes without statistics. I have older batches for which I get the statistics when making a similar call (obviously, with the appropriate search time interval). Are the statistics not available immediately for a settled batch? I've never noticed this behavior before but then I am not sure I ever tested the GetSettledBatchList method so soon after a batch was closed.

 

Any idea what is going on? The batch number, if you can look at it internally is 3952690.

 

Thanks,

Ed


Accepted Solutions
Solution
Accepted by topic author EddieLascu88CNP
‎08-21-2015 01:58 AM
Administrator Administrator
Administrator
Posts: 563
Registered: ‎08-03-2011

Re: Batch Statistics not returned by the GetSettledBatchList in the Test Environment

 

Hi Ed,

 

We cannot recreate the behavior you are seeing. Can you please send us an email at Developer@Authorize.Net with the exact API request you are sending so we can check this for you.

 

Thanks,

Joy

View solution in original post


All Replies
Regular Contributor
Posts: 64
Registered: ‎10-03-2013

Re: Batch Statistics not returned by the GetSettledBatchList in the Test Environment

*** Bump ***

 

I notice that statistics are still not available in the test environemtn for all the batches that settled in the last couple of days. Does anyone else experience a similar thing? Is this a temporary problem? Statistics are not available when I request them either by calling GetSettledBatchList and passing the includeStatistics flag as true or when I use GetBatchStatistics for a particular batch identified by its unique id. Can anyone shed some light on this issue?

 

Thanks,

Ed

Solution
Accepted by topic author EddieLascu88CNP
‎08-21-2015 01:58 AM
Administrator Administrator
Administrator
Posts: 563
Registered: ‎08-03-2011

Re: Batch Statistics not returned by the GetSettledBatchList in the Test Environment

 

Hi Ed,

 

We cannot recreate the behavior you are seeing. Can you please send us an email at Developer@Authorize.Net with the exact API request you are sending so we can check this for you.

 

Thanks,

Joy

Regular Contributor
Posts: 64
Registered: ‎10-03-2013

Re: Batch Statistics not returned by the GetSettledBatchList in the Test Environment

Hi Joy,

 

I sent you an email with details and screen shots at the provided address.

 

Thanks,

Eddie

Regular Contributor
Posts: 64
Registered: ‎10-03-2013

Re: Batch Statistics not returned by the GetSettledBatchList in the Test Environment

This issue is now resolved. After I refreshed the references to the SOAP Service everything started working again.