Integration and Testing

Authorize.Net API questions and help with your payment integration.

Reply
Member
Posts: 3
Registered: ‎05-03-2019

Billing address is being transferred in production.

I am using PHP SDK for payment. While in testing mode(Sandbox) its tranferred the billing address perfectly to API. But after changing the testing mode to PRODUCTION. Billing address is not being passed.

 

Can anyone tell me where is the problem

All Star
Posts: 733
Registered: ‎11-05-2018

Re: Billing address is being transferred in production.

If you’re using a test account, you are in Sandbox all the time. If you are in a live real money account, you need to change your post url, API credentials, and then change the environment to production.
All Star
Posts: 733
Registered: ‎11-05-2018

Re: Billing address is being transferred in production.

And I’m not sure what you mean “passed to the API”. If you’re on a live, real money account in test mode, there is no transaction data retained. So sandbox accounts are for your simulation and production accounts are for doing real transactions. The only function test mode really has on a production account is to test your credentials. If you are in a production account in test mode and are using the same set of scripts you used on the sandbox, once you move your production account to live mode it should work just like your sandbox. The only thing that could hold you up is if your MSP has something wrong on their end. Otherwise sandbox is a 100% simulation of a live account.
Member
Posts: 3
Registered: ‎05-03-2019

Re: Billing address is being transferred in production.

By "Being passed" i mean transferred. Okay as you said i have changed everything still the result is same.

 

When i am in test mode i am using test account and when in live mode I changed it to production with production credentail. 

 

My problem is while in testing mode if I pass billing address to api(Through SDK) it works(I can see them in my sandbox dashboard). But after changing everthing to production with production credential. the billing address is not being received by API(Authorize.net api)

 

Is there anything i have to update.

 

All Star
Posts: 733
Registered: ‎11-05-2018

Re: Billing address is being transferred in production.

You have a button to toggle on your production account to move from test mode to live mode. Have you done this? The way you would tell is you would have to use a real credit card with real money to use your production account in live mode. 

Member
Posts: 3
Registered: ‎05-03-2019

Re: Billing address is being transferred in production.

I also did that

All Star
Posts: 733
Registered: ‎11-05-2018

Re: Billing address is being transferred in production.

Well then I have no idea. If you want further help, post your entire payment script and I'll be on the lookout.