Integration and Testing

Authorize.Net API questions and help with your payment integration.

Reply
Member
Posts: 1
Registered: ‎09-24-2012

CIM API for createCustomerProfileRequest blank shipping info (kind of)???

Hello all,

 

I'm having a strange problem that I am unable to figure out.  We recently switched over to Authnet CIM integration and I am making 2 calls during our checkout process.  The first is createCustomerProfileRequest, in which I send over the profile information, a payment profile, and the shipping address.  Next I do a createCustomerTransactionRequest to bill the card against the profile I just created.

 

The problem I'm having is that we have fraud protection turned on, with shipping address verification.  When I first call the createCustomerProfileRequest it does an auth only transaction using the details provided (b/c the validation mode is other than 'none').  Now, my API call creates the profile info, the payment info, and the shipping info within the client record just fine.  But the transaction email that is generated from test authorization has all the shipping info as blank, so the transaction is being flagged  as suspicious because it is somehow not passing along the shipping address for the card validation.

 

But I know that my createCustomerProfileRequest call is getting the  valid shipping fields because it creates the shipping address in the CIM record just fine, and passes back the shipping ID that I then use to create the transaction.  All of this works correctly, but for some reason on that initial createProfile call when it does the test auth it's not registering the shipping address I passed in.  It is not making any sense to my why it would create the shipping address in the system and pass back a valid id, while simultaneously sending me an email saying the shipping info is blank.

 

I assume there is something I am missing?  Has anyone experience something similar?  I apologize if this has been asked before, i searched every term I could think of and could not find someone with a simlar problem.

 

Help!

 

Thank you,

Jeff

Posts: 1,609
Topics: 15
Kudos: 209
Solutions: 121
Registered: ‎06-23-2011

Re: CIM API for createCustomerProfileRequest blank shipping info (kind of)???

I'm a bit confused here. Are you saying that you're getting an email for the validation $0.01 transaction without a shipping address, or an email for the real transaction without the shipping address.