Reply
Highlighted
Member
Posts: 2
Registered: ‎10-16-2014
Accepted Solution

CIM CreateCustomerProfile data with non-ascii characters is not stored.

Recently we've been experiencing some problems with customers whose personal data contains non-ascii characters.

 

More precisely, I find that making a call to CreateCustomerProfile with UTF-8 encoded user data is problematic: the call succeeds, but when I inspect the customer profile on the server (either by looking it up directly in my account page, or by calling GetCustomerProfile) I find that the user data is not there.

 

Below is the XML for the CreateCustomerProfile. The values for firstName, lastName, address are UTF-8 encoded characters outside the ISO-8895-1 character set (Korean characters).

 

My questions:

 

  1. 1. Am I doing something wrong? Do I need to use a different encoding?
  2. 2. If not, can you give me some input as to what character sets are supported?

Thanks!

 

<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns0="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="https://api.authorize.net/soap/v1/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <SOAP-ENV:Header />
  <ns0:Body>
    <ns1:CreateCustomerProfile>
      <ns1:merchantAuthentication>
        <ns1:name>xxx</ns1:name>
        <ns1:transactionKey>yyy</ns1:transactionKey>
      </ns1:merchantAuthentication>
      <ns1:profile>
        <ns1:merchantCustomerId>911c688b59864ce3bb53</ns1:merchantCustomerId>
        <ns1:paymentProfiles>
          <ns1:CustomerPaymentProfileType>
            <ns1:customerType>individual</ns1:customerType>
            <ns1:billTo>
              <ns1:firstName>\xec\x82\xbc</ns1:firstName>
              <ns1:lastName>\xec\x8a\xb9</ns1:lastName>
              <ns1:address>\xea\xb0\x95\xeb\x82\xa8</ns1:address>
              <ns1:country>US</ns1:country>
            </ns1:billTo>
            <ns1:payment>
              <ns1:creditCard>
                <ns1:cardNumber>4111111111111111</ns1:cardNumber>
                <ns1:expirationDate>2020-12</ns1:expirationDate>
                <ns1:cardCode>123</ns1:cardCode>
              </ns1:creditCard>
            </ns1:payment>
          </ns1:CustomerPaymentProfileType>
        </ns1:paymentProfiles>
      </ns1:profile>
      <ns1:validationMode>none</ns1:validationMode>
    </ns1:CreateCustomerProfile>
  </ns0:Body>
</SOAP-ENV:Envelope>

 


Accepted Solutions
Highlighted
Solution
Accepted by topic author jvkersch
‎08-21-2015 01:58 AM
Posts: 2,765
Topics: 57
Kudos: 245
Blog Posts: 67
Registered: ‎12-05-2011

Re: CIM CreateCustomerProfile data with non-ascii characters is not stored.

Hello @jvkersch 

 

We currently support iso-8859-1 encoding.  I've reported this to our product team for support in a future release.


I'd recommend subscribing to this topic so that you'll be alerted via email if there are updates. To subscribe, click Topic Options at the top of this thread and then select Subscribe. You'll then receive an email once anyone replies to your post.

Thanks,

Richard

View solution in original post


All Replies
Highlighted
Solution
Accepted by topic author jvkersch
‎08-21-2015 01:58 AM
Posts: 2,765
Topics: 57
Kudos: 245
Blog Posts: 67
Registered: ‎12-05-2011

Re: CIM CreateCustomerProfile data with non-ascii characters is not stored.

Hello @jvkersch 

 

We currently support iso-8859-1 encoding.  I've reported this to our product team for support in a future release.


I'd recommend subscribing to this topic so that you'll be alerted via email if there are updates. To subscribe, click Topic Options at the top of this thread and then select Subscribe. You'll then receive an email once anyone replies to your post.

Thanks,

Richard

Highlighted
Member
Posts: 2
Registered: ‎10-16-2014

Re: CIM CreateCustomerProfile data with non-ascii characters is not stored.

Dear Richard,

 

Thanks for the confirmation, this is good to know. Will definitely stay alert for future updates.