Reply
Contributor
Posts: 12
Registered: ‎11-16-2011

CIM - OpenEditShippingPopup giving me "Missing Payment Profile ID"

Having trouble integrating the Edit Payment popup (and Edit Shipping Popup as well) with my test account.

 

I am properly getting a hosted token, and I know this because I see it and also when I attach to the button the openAddPaymentPopup() call, the popup comes up with the proper customer and the correct payment and shipping info.

 

However, when I call the function to edit a particular payment, I get the missing ID message in the popup.  I even hard coded a legit payment ID in the call, as shown here:

 

<button onclick="AuthorizeNetPopup.openEditShippingPopup('5032582')">Edit Payment Info</button>

 

The ID shown is an actual payment profile ID from the customer referenced, the same customer ID I used to get the token, which was successful.  I hard coded a legitimate payment profile ID to be sure the right thing was getting passed to the popup, but I always get the Missing ID message.

 

Any ideas on what I am doing wrong?  It makes no sense to me that calling Addpaymentpopup works fine for the customer in question but the Edit does nto work.  Is the documentation accurate?  Do I need to pass the customer ID as well as the payment profile ID?  I am following the sample code as well as the docs, so there does not seem to be any reason why it would not work.

Highlighted
Posts: 1,609
Topics: 15
Kudos: 200
Solutions: 121
Registered: ‎06-23-2011

Re: CIM - OpenEditShippingPopup giving me "Missing Payment Profile ID"

Yes, it has to be a customer profile ID, since shipping addresses are associated with the customer and not just 1:1 to payment profiles.