Reply
Highlighted
Regular Contributor
Posts: 55
Registered: ‎04-22-2011

CIM Refund E00051 Issue

Back in August, Authorize.Net had an issue with CIM where refunds would frequently fail on the first attempt with an E00051 error, indicating that "The original transaction was not issued for this payment profile." A second attempt typically succeeded. The issue occurred both via our system and via the CIM tool Authorize.Net Web site. I reported this original in customer support ticket 1-86594811, and it was eventually fixed on or around August 16th.

 

I've re-opened that ticket but am repeating it here with hopes that the Authorize.Net developers will see it more quickly since Customer Support usually gives the runaround.

 

While the problem didn't occur for the many months since the original resolution, the problem has started appearing again this week as of January 26th. I can recreate the issue within the Authorize.Net Web interface:

 

(1) Go to Tools > Customer Information Manager

(2) Find a profile with a refund, and click the Refund button,

(3) Paste in an original transaction ID so that it is a linked refund, and issue a refund for an amount like $1.

 

The first attempt will intermittently fail with E00051. Clicking back and pasting in the same values again succeeds. Would someone look into this issue?

Highlighted
Posts: 2,765
Topics: 57
Kudos: 245
Blog Posts: 67
Registered: ‎12-05-2011

Re: CIM Refund E00051 Issue

Hello @npiasecki 

 

Before I escalate your issue, could you confirm if you are also able to reproduce this in the sandbox?  Are you using an SDK or API?

 

Richard

Highlighted
Regular Contributor
Posts: 55
Registered: ‎04-22-2011

Re: CIM Refund E00051 Issue

I don't have any settled transactions in the sandbox, so I can't test refunds there as far as I know.

 

I am using the SOAP API. I can also recreate it via the Authorize.Net CIM tool in the Merchant Interface. I'm not sure what the Merchant Interface is using underneath, but the problem seems to be common to both.

Highlighted
Posts: 2,765
Topics: 57
Kudos: 245
Blog Posts: 67
Registered: ‎12-05-2011

Re: CIM Refund E00051 Issue

Thanks again, we'll get to work on this.

 

Richard

Highlighted
Regular Contributor
Posts: 55
Registered: ‎04-22-2011

Re: CIM Refund E00051 Issue

Customer Support asked for a bunch of questions about my setup, but I'm not sure how that is relevant since I can create it through the Authorize.Net Web site. If you can view ticket 1-86594811, I added a link to a video of me recreating the issue in the Authorize.Net Web site just now.

Highlighted
Regular Contributor
Posts: 55
Registered: ‎04-22-2011

Re: CIM Refund E00051 Issue

I can recreate the issue in the Authorize.Net CIM Web interface for two different gateway accounts, so it doesn't seem to be limited to a particular gateway account.