Integration and Testing

Authorize.Net API questions and help with your payment integration.

Reply
Posts: 333
Kudos: 73
Solutions: 36
Registered: ‎03-13-2017

Re: CIM SOAP API returning a 550 error on sandbox and production

Hi @bilderbach

 

Are you also using authorizesauce  for integration ?

 

Thanks





Send feedback at developer_feedback@authorize.net
Member
Posts: 3
Registered: ‎04-18-2018

Re: CIM SOAP API returning a 550 error on sandbox and production

We are also seeing this problem, and we are also using the authorizesauce library.

 

Interestingly enough not seeing this on our staging environment pointing to the Authorize.net sandbox - only seems to happen in the production environment.

Member
Posts: 5
Registered: ‎04-18-2018

Re: CIM SOAP API returning a 550 error on sandbox and production

authorizesauce was working as late as 10:45 a.m. central on April 18th. Whatever the issue is, it is not with the library, but with a change made on your side.

Member
Posts: 2
Registered: ‎04-18-2018

Re: CIM SOAP API returning a 550 error on sandbox and production

 

Here is the request and response for calling 'CreateCustomerProfile' in sanbox at 'https://api.authorize.net/soap/v1/CreateCustomerProfile'.

 

Request

<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:ns0="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="https://api.authorize.net/soap/v1/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
   <SOAP-ENV:Header/>
   <ns0:Body>
      <ns1:CreateCustomerProfile>
         <ns1:merchantAuthentication>
            <ns1:name>XXX</ns1:name>
            <ns1:transactionKey>XXX</ns1:transactionKey>
         </ns1:merchantAuthentication>
         <ns1:profile>
            <ns1:merchantCustomerId>ddbdeee855d948398353</ns1:merchantCustomerId>
            <ns1:email>joe@test.com</ns1:email>
            <ns1:paymentProfiles>
               <ns1:CustomerPaymentProfileType>
                  <ns1:customerType>individual</ns1:customerType>
                  <ns1:billTo>
                     <ns1:firstName>Joe</ns1:firstName>
                     <ns1:lastName>Blow</ns1:lastName>
                     <ns1:address>1234 Street</ns1:address>
                     <ns1:city>Irvine</ns1:city>
                     <ns1:state>CA</ns1:state>
                     <ns1:country>US</ns1:country>
                  </ns1:billTo>
                  <ns1:payment>
                     <ns1:creditCard>
                        <ns1:cardNumber>4111111111111111</ns1:cardNumber>
                        <ns1:expirationDate>2018-11</ns1:expirationDate>
                        <ns1:cardCode>911</ns1:cardCode>
                     </ns1:creditCard>
                  </ns1:payment>
               </ns1:CustomerPaymentProfileType>
            </ns1:paymentProfiles>
            <ns1:profileType/>
         </ns1:profile>
         <ns1:validationMode>none</ns1:validationMode>
      </ns1:CreateCustomerProfile>
   </ns0:Body>
</SOAP-ENV:Envelope>

Response

 

 

<?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope xmlns:ns0="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="https://api.authorize.net/soap/v1/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Header/><ns0:Body><ns1:CreateCustomerProfile><ns1:merchantAuthentication><ns1:name>6V46Shu5J</ns1:name><ns1:transactionKey>682G5yFJyc485uJF</ns1:transactionKey></ns1:merchantAuthentication><ns1:profile><ns1:merchantCustomerId>ddbdeee855d948398353</ns1:merchantCustomerId><ns1:email>drewisme@gmail.com</ns1:email><ns1:paymentProfiles><ns1:CustomerPaymentProfileType><ns1:customerType>individual</ns1:customerType><ns1:billTo><ns1:firstName>Joe</ns1:firstName><ns1:lastName>Blow</ns1:lastName><ns1:address>1234 Street</ns1:address><ns1:city>Irvine</ns1:city><ns1:state>CA</ns1:state><ns1:country>US</ns1:country></ns1:billTo><ns1:payment><ns1:creditCard><ns1:cardNumber>4111111111111111</ns1:cardNumber><ns1:expirationDate>2018-11</ns1:expirationDate><ns1:cardCode>911</ns1:cardCode></ns1:creditCard></ns1:payment></ns1:CustomerPaymentProfileType></ns1:paymentProfiles><ns1:profileType/></ns1:profile><ns1:validationMode>none</ns1:validationMode></ns1:CreateCustomerProfile></ns0:Body></SOAP-ENV:Envelope>
HTTP failed - 550 - Unknown:

 

 

Member
Posts: 2
Registered: ‎04-19-2018

Re: CIM SOAP API returning a 550 error on sandbox and production

Hi,

 

Is this issue resolved completely? We are facing the same problem when tried to use the function UpdateCustomerProfile. 

 

https://api.authorize.net/soap/v1/UpdateCustomerProfile 

 

Thank you.

Member
Posts: 1
Registered: ‎04-19-2018

Re: CIM SOAP API returning a 550 error on sandbox and production

@drewisme You forgot to redact your credentials in the response. The whole request XML structure is on the first line.
Member
Posts: 2
Registered: ‎04-19-2018

Re: CIM SOAP API returning a 550 error on sandbox and production

[ Edited ]

The issues are still present. The SOAP API is returning a HTTP 550 Unknown response for valid and previously working requests.

 

The issue is not library dependent. You can make the request and see the response using the information posted by drewisme.

 

This has happened before and is likely the same IIS misconfiguration that was eventually resolved by authorize.net (https://community.developer.authorize.net/t5/Integration-and-Testing/Sandbox-Accept-js-seems-to-be-d...).

 

This is a critical issue that needs more attention. While the SOAP API is depracted this is effectively a sudden end of life of a mission critical service.

Member
Posts: 8
Registered: ‎11-11-2013

Re: CIM SOAP API returning a 550 error on sandbox and production

same here, call center is down behind this!

Member
Posts: 3
Registered: ‎04-18-2018

Re: CIM SOAP API returning a 550 error on sandbox and production

Other departments in our organization are also having this issue, they use the SOAP API as well but do not use AuthorizeSauce (or even Python for that matter) so second the notion that this is more widespread than the original response of "don't use that library".  There was clearly a breaking change introduced on the Authorize.NET SOAP API side.

 

It would be nice (at the very least) to get an official acknowledgement of an issue from Authorize.NET.  My direct support ticket has been sent to "development" but has been generally unhelpful, especially considering our production system is down due to this.

Member
Posts: 5
Registered: ‎04-18-2018

Re: CIM SOAP API returning a 550 error on sandbox and production

Would everyone please share their case numbers? Our case has yet to be reviewed by an enginner (since 10PM EST last evening) and I'm attempting to compel support to further escalate the matter.

 

05001577