Reply
Member
Posts: 3
Registered: ‎12-14-2012

CIM create customer profile has stopped working recently with liveMode and live account credentials

Suddently on our Magento site with AuthnetCIM, create customer profile , create payment profiles has stopped working.

Even Old profiles are not getting listed on //store/authnetcim/manage/ page.

 

Authnetcim is configured with production account credentials and is set to use 

       Validation Type - liveMode

       Authorize.Net Test Mode -  No

       Payment Action - Authorize Only.

 

Please  suggest any reson for the issue or solution.

Thanks

 

 

 

 

 

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: CIM create customer profile has stopped working recently with liveMode and live account credenti

Someone changed the transactionKey? can you find out what the Exxxx error is from authorize.net?

Member
Posts: 3
Registered: ‎12-14-2012

Re: CIM create customer profile has stopped working recently with liveMode and live account credenti

The Transaction ket and login ID are correct. Also payment authorization and capture works just fine.

Only saving new customer profiles and old profiles are not getting fetched in magento.

 

For get customer profiles it doesnt throw any error too

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: CIM create customer profile has stopped working recently with liveMode and live account credenti

It might be a magento problem, if there isn't any error code from authorize.net

Member
Posts: 3
Registered: ‎12-14-2012

Re: CIM create customer profile has stopped working recently with liveMode and live account credenti

While creating a new payment profile this is the response that we get in magento-

 

<?xml version="1.0" encoding="utf-8"?><createCustomerPaymentProfileResponse xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="AnetApi/xml/v1/schema/AnetApiSchema.xsd"><messages><resultCode>Error</resultCode><message><code>E00027</code><text>This transaction has been declined.</text></message></messages><validationDirectResponse>2,1,2,This transaction has been declined.,,S,4894129507,none,Test transaction for ValidateCustomerPaymentProfile.,0.01,CC,auth_only,none,Test,Test,,234 Street,New York,New York,10013-8765,US,1255555875,,email@example.com,,,,,,,,,0.00,0.00,0.00,FALSE,none,Bhfhfhgfhgfhgfgfdghfgf,P,,,,,,,,,,,,XXXX,MasterCard,,,,,,,,,,,,,,,,</validationDirectResponse></createCustomerPaymentProfileResponse>

 

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: CIM create customer profile has stopped working recently with liveMode and live account credenti

It got decline by the credit card issuing bank. It that just one card or any credit cards?

Can you set the validationMode to testmode to save the payment profile then run a few dollars auth_only transaction against the payment profile to see if it work? If that work, call authorize.net, it might be a settings issue.

Member
Posts: 1
Registered: ‎03-07-2013

Re: CIM create customer profile has stopped working recently with liveMode and live account credenti

How do you know the card was declined by the issuing bank here? I have a similar problem and have no idea why it is being declined.

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: CIM create customer profile has stopped working recently with liveMode and live account credenti

because of

<validationDirectResponse>2,1,2,This transaction has been declined.,,