Reply
Member
Posts: 3
Registered: ‎05-28-2019

CIM - getCustomerProfileRequest: Multiple records found.

In the last few days every request to getCustomerProfileRequest using the email is returning the error:

 

Multiple records found. Please refine search options.

 

Our integration has been using that method with a unique email for many years now without a problem.  Suddenly we aren't able to retrieve any profles.  We did a check loading all profiles and looking for any duplicate emails and there are none.  Does anyone know the cause of this and how to avoid it?  We are working on a fix to store the profile id locally but that will likely take longer than what appears to be a new issue with the API.

Member
Posts: 3
Registered: ‎05-28-2019

Re: CIM - getCustomerProfileRequest: Multiple records found.

No response from Authorize.net and no feedback and no changes to the integration and it magically just started working again.  It would be nice to know what happened.

Posts: 2,765
Topics: 57
Kudos: 245
Blog Posts: 67
Registered: ‎12-05-2011

Re: CIM - getCustomerProfileRequest: Multiple records found.

Hello @inverge

 

I checked with our support specialists and we have not made any system changes recently, nor do we have any similar reports escalated to them.  Did you by chance open a case with support we could reference?

 

Richard

 

 

Highlighted
Member
Posts: 3
Registered: ‎05-28-2019

Re: CIM - getCustomerProfileRequest: Multiple records found.

[ Edited ]

I haven't received any response from support with any case number.