Reply
Highlighted
Member
Posts: 2
Registered: ‎09-10-2013
Accepted Solution

CIM hosted page will not submit after saving account info...

Hello,

 

I have read the two other threads i could find on this subject but still have not been able to solve this problem.  From what i can tell this is a cross site scrpting/iframe issue. this issue only materializes for some people on older systems/browsers such as: Firefox 23.0.1 on windows 7 while the same browser has no problems in windows 8.

 

The problem for those not familar with it is that the submit button on the CIM iframe screen after the account info has been entered and saved successfully fails to submit the form and thus close the iframe and move on. How could the first page of the iframe sequence work correctly but the last not?

 

We have the "IframeCommunicator.html" script but i cannot see where or how it is implemented. We make simple xml calls back and fourth between the CIM and our scripts to do all manner of profile creation/deleting/transactions etc... without any trouble.

 

What can we do with this IframeCommunicator.html script to solve this problem? where and how is it used?

 

Thanks.

 


Accepted Solutions
Highlighted
Solution
Accepted by RichardH (Administrator)
‎08-21-2015 01:58 AM
Member
Posts: 2
Registered: ‎09-10-2013

Re: CIM hosted page will not submit after saving account info...

this problem has been solved, it turns out we were leaving a secure page for a non secure   "hostedProfileReturnUrl" page.  understandabley some browser security settings did not like this.  so the problem is resolved by using a secure (https://) URL for this setting.

View solution in original post


All Replies
Highlighted
Posts: 1,609
Topics: 15
Kudos: 201
Solutions: 121
Registered: ‎06-23-2011

Re: CIM hosted page will not submit after saving account info...

The form does submit, it just doesn't trigger the onPopupClosed() Javascript function, probably because of lack of support for cross-domain interactions in older browsers. My ancient Mac's browsers have the same problem, though my newer Mac and PC work just fine. In the absence of an easy fix, the best thing to do for now is pop up a div next to the iframe telling people to refresh the page if the form just sits there when they press submit. Or at least that's what I've been doing, I don't know if anyone else has come up with a more elegant solution.

Highlighted
Solution
Accepted by RichardH (Administrator)
‎08-21-2015 01:58 AM
Member
Posts: 2
Registered: ‎09-10-2013

Re: CIM hosted page will not submit after saving account info...

this problem has been solved, it turns out we were leaving a secure page for a non secure   "hostedProfileReturnUrl" page.  understandabley some browser security settings did not like this.  so the problem is resolved by using a secure (https://) URL for this setting.