Reply
Highlighted
Contributor
Posts: 34
Registered: ‎09-29-2016

CIM request errors - Connection Closed

Hi,

 

I asked this a while back but this is an error I see occur randomly and seemingly without cause when we send requests over using CIM requests.

 

Outer Exception : The underlying connection was closed: An unexpected error occurred on a send.
Inner Exception : Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.
Inner Exception : An existing connection was forcibly closed by the remote host

 

I am not sure if this is a firewall issue on our end, or if for some reason Authorize.Net is closing the request (C# WebRequest).

 

Have you seen others with the issue before? What steps can I take to try and figure out why this issue happens sometimes and not other times with no code changes on my end?

 

Thanks!

Highlighted
Member
Posts: 4
Registered: ‎12-07-2016

Re: CIM request errors - Connection Closed

[ Edited ]

hello,

 

We've been experiencing similar issues, but with the standard payment API (we're using the java SDK).  Turns out this has been happening for months but seems to be occurring more frequently now.  Specifically, when we check for NULL on the API response object, it is indeed NULL...maybe 95% of the time the transaction goes through OK.  Sometimes the NULL response object is detected almost immediately after making the request, and sometimes it will hang for 20-30 seconds.

Some unknown % of these failures actually resulted in a sucessful payment, which is obviously really really bad be/c we have no record of it.

 

We've had a few interactions with someone actually at Authorize.net, but it hasn't been helpful at all - they seem to be claiming there is a network connection drop on our end.  We are now considering full abandonment of Authorize.net, which is unfortunate.  If this issue were extremeley rare, we could live with it...but at this point it's happening too often.

 

I've also investigated "work-arounds", perhaps through their webhook API or pulling unsettled transactions to try to "reconcile".  But this effort might be better spent on integrating with a different gateway provider.

 

Bob

 

Highlighted
Regular Contributor
Posts: 50
Registered: ‎05-31-2016

Re: CIM request errors - Connection Closed

I posted my own message about receiving a NULL response from Authorize.net but I thought I'd keep this alive by sharing our experience here as well.

 

After installing monitoring for this, we had no problems for a week, then Tuesday 12/13/16 about 3:00PM it started. In the next 24 hours we had 14 null responses. It subsided about 1:45PM yesterday.

This morning we had another one.

 

We are using the PHP API (net\authorize\api\contract\v1)

 

- Don

Highlighted
Posts: 2,765
Topics: 57
Kudos: 248
Blog Posts: 67
Registered: ‎12-05-2011

Re: CIM request errors - Connection Closed

Are you experiencing these issue in production, sandbox, or both?

Highlighted
Regular Contributor
Posts: 50
Registered: ‎05-31-2016

Re: CIM request errors - Connection Closed

[ Edited ]

Production only, I can't get it to reproduce in sandbox.

 

- Don

Highlighted
Posts: 2,765
Topics: 57
Kudos: 248
Blog Posts: 67
Registered: ‎12-05-2011

Re: CIM request errors - Connection Closed

@fifty-git

 

I would recommend calling customer support right away, and ask for escalation to a support specialist.  You can reach customer service at 877-447-3938.

 

Richard