Reply
Highlighted
Member
Posts: 1
Registered: ‎01-16-2020

Certificate Update when using the PHP SDK?

With the network change from Akami to Cloudflare, authorize.net has set up a (somewhat confusing) FAQ that tells us to update a certificate.

Do we also need to update the certificate if we're using the official PHP SDK API from the Github repository?

There's a cert.pem file in /lib/ssl, which does contain a couple of Entrust certificates, which is the same company for which the new certificate should be installed, so it might be affected by the change. Or not. Nobody really tells us.


There's also an open issue since November 2019 on the Github tracker regarding this, but no official answer has been given so far.

Maybe someone here will see this and can give a definitive answer.

 

I did check the certificates in the cert.pem file one by one, and all seem to be valid for 2026+, so it might be ok. But maybe not, some official answer would be really appreciated.

Highlighted
Member
Posts: 1
Registered: ‎01-17-2020

Re: Certificate Update when using the PHP SDK?

You may target users in one of three ways using this method: by Segment, by Filter, or by Device. ... Use the same id to update an existing notification instead of showing a new one. ...  Cinderella Solution Review