Reply
Member
Posts: 9
Registered: ‎06-10-2019

Constantly receiving 200 error messages fron conneting my Sandbox to WooCommerce

I've been attempting to connect a new store I'm developing in WooCommerce to my Sandbox account. I've got my Sandbox set to LIVE instead of TEST and I've set both my Woo settings to both Test as well as Production with the proper login ID and API keys. I've changed both my keys many, many times to no effect.

 

When I try to checkout, I always receive a 200 error that the order didn't complete.

When I get to the checkout, I get the following errors:

Request
method: POST
uri: https://api2.authorize.net/xml/v1/request.api
user-agent: WooCommerce-Authorize.Net-Gateway/3.0.3 (WooCommerce/3.6.4; WordPress/5.2.1)
headers: Array
(
[content-type] => application/xml
[accept] => application/xml
)
body: <?xml version="1.0" encoding="UTF-8"?>
<getMerchantDetailsRequest xmlns="AnetApi/xml/v1/schema/AnetApiSchema.xsd">
<merchantAuthentication>
<name>********</name>
<transactionKey>****************</transactionKey>
</merchantAuthentication>
</getMerchantDetailsRequest>
duration: 0.77377s
Response
code: 200
message: OK
headers: Array
(
[cache-control] => no-store
[pragma] => no-cache
[content-type] => application/xml; charset=utf-8
[x-opnet-transaction-trace] => a2_a4b557e9-8242-42a7-9c8d-7ba0d1b5aaec-22356-3177605
[access-control-allow-credentials] => true
[access-control-allow-headers] => x-requested-with,cache-control,content-type,origin,method,SOAPAction
[access-control-allow-methods] => PUT,OPTIONS,POST,GET
[access-control-allow-origin] => *
[strict-transport-security] => max-age=31536000
[x-cnection] => close
[content-length] => 411
[date] => Mon, 10 Jun 2019 21:39:35 GMT
)
body: <?xml version="1.0" encoding="utf-8"?>
<getMerchantDetailsResponse>
<messages>
<resultCode>Error</resultCode>
<message>
<code>E00007</code>
<text>User authentication failed due to invalid authentication values.</text>
</message>
</messages>
</getMerchantDetailsResponse>
Request
method: POST
uri: https://api2.authorize.net/xml/v1/request.api
user-agent: WooCommerce-Authorize.Net-Gateway/3.0.3 (WooCommerce/3.6.4; WordPress/5.2.1)
headers: Array
(
[content-type] => application/xml
[accept] => application/xml
)
body: <?xml version="1.0" encoding="UTF-8"?>
<getMerchantDetailsRequest xmlns="AnetApi/xml/v1/schema/AnetApiSchema.xsd">
<merchantAuthentication>
<name>********</name>
<transactionKey>****************</transactionKey>
</merchantAuthentication>
</getMerchantDetailsRequest>
duration: 0.32984s
Response
code: 200
message: OK
headers: Array
(
[cache-control] => no-store
[pragma] => no-cache
[content-type] => application/xml; charset=utf-8
[x-opnet-transaction-trace] => a2_5c8778b3-4047-4085-93a5-a0f9773a5612-28052-3180044
[access-control-allow-credentials] => true
[access-control-allow-headers] => x-requested-with,cache-control,content-type,origin,method,SOAPAction
[access-control-allow-methods] => PUT,OPTIONS,POST,GET
[access-control-allow-origin] => *
[strict-transport-security] => max-age=31536000
[x-cnection] => close
[content-length] => 411
[date] => Mon, 10 Jun 2019 21:39:35 GMT
)
body: <?xml version="1.0" encoding="utf-8"?>
<getMerchantDetailsResponse>
<messages>
<resultCode>Error</resultCode>
<message>
<code>E00007</code>
<text>User authentication failed due to invalid authentication values.</text>
</message>
</messages>
</getMerchantDetailsResponse>
Request
method: POST
uri: https://api2.authorize.net/xml/v1/request.api
user-agent: WooCommerce-Authorize.Net-Gateway/3.0.3 (WooCommerce/3.6.4; WordPress/5.2.1)
headers: Array
(
[content-type] => application/xml
[accept] => application/xml
)
body: <?xml version="1.0" encoding="UTF-8"?>
<getMerchantDetailsRequest xmlns="AnetApi/xml/v1/schema/AnetApiSchema.xsd">
<merchantAuthentication>
<name>********</name>
<transactionKey>****************</transactionKey>
</merchantAuthentication>
</getMerchantDetailsRequest>
duration: 0.49695s
Response
code: 200
message: OK
headers: Array
(
[cache-control] => no-store
[pragma] => no-cache
[content-type] => application/xml; charset=utf-8
[access-control-allow-credentials] => true
[access-control-allow-headers] => x-requested-with,cache-control,content-type,origin,method,SOAPAction
[access-control-allow-methods] => PUT,OPTIONS,POST,GET
[access-control-allow-origin] => *
[strict-transport-security] => max-age=31536000
[x-cnection] => close
[content-length] => 411
[date] => Mon, 10 Jun 2019 21:39:38 GMT
)
body: <?xml version="1.0" encoding="utf-8"?>
<getMerchantDetailsResponse>
<messages>
<resultCode>Error</resultCode>
<message>
<code>E00007</code>
<text>User authentication failed due to invalid authentication values.</text>
</message>
</messages>
</getMerchantDetailsResponse>
Posts: 2,765
Topics: 57
Kudos: 245
Blog Posts: 67
Registered: ‎12-05-2011

Re: Constantly receiving 200 error messages fron conneting my Sandbox to WooCommerce

Hello @databell96 

 

The actual error within the response body is what you should use:

 

<code>E00007</code>
<text>User authentication failed due to invalid authentication values.</text>

 

https://developer.authorize.net/api/reference/responseCodes.html?code=E00007

 

Richard

 

 

Member
Posts: 9
Registered: ‎06-10-2019

Re: Constantly receiving 200 error messages fron conneting my Sandbox to WooCommerce

I know that. But the thing is I constantly reset the API keys and each and every time, it comes up
as invalid. No matter what. This makes no sense.

I know what is happening but what I need to know is what can be done to fix it.

And again, no matter how many times I reset it, it doesn’t take.
Posts: 2,765
Topics: 57
Kudos: 245
Blog Posts: 67
Registered: ‎12-05-2011

Re: Constantly receiving 200 error messages fron conneting my Sandbox to WooCommerce

@databell96 

 

Please note that our Sandbox and Production systems are completely separate and you cannot use credentials from one system with the other.

 

Let me suggest trying the following:

  • Log into the sandbox at https://sandbox.authorize.net and reset your credentials
  • Then go to the try it tab in the API Reference and add your new credentials
  • Confirm you can submit a transaction
  • Then move to your system, configure WooCommerce for our sandbox and use credentials.

If this works, then you simply need new production credentials and follow similar steps.

 

Richard

Member
Posts: 9
Registered: ‎06-10-2019

Re: Constantly receiving 200 error messages fron conneting my Sandbox to WooCommerce

The Try It tab? I'm in the reference page and I don't see a Try It tab anywhere. I did reset my password though.

Highlighted
Posts: 2,765
Topics: 57
Kudos: 245
Blog Posts: 67
Registered: ‎12-05-2011

Re: Constantly receiving 200 error messages fron conneting my Sandbox to WooCommerce

Sorry about that, been a while since I've used the console.

 

Use the API Live Console

 

https://developer.authorize.net/api/reference/#payment-transactions-charge-a-credit-card

 

Richard

Member
Posts: 9
Registered: ‎06-10-2019

Re: Constantly receiving 200 error messages fron conneting my Sandbox to WooCommerce

I have no idea how to use that.

Member
Posts: 9
Registered: ‎06-10-2019

Re: Constantly receiving 200 error messages fron conneting my Sandbox to WooCommerce

OK, I think I know what to do. I went to the Charge a Credit Card section. In the API Live Console, I substituted my Login ID in the name area and the Transaction Key in that spot. Clicked SEND and I got a response back of  "This Transaction has been approved".

So I'm guessing it's not authorize.net but rather my server?

All Star
Posts: 577
Registered: ‎11-05-2018

Re: Constantly receiving 200 error messages fron conneting my Sandbox to WooCommerce

[ Edited ]

@databell96 

 

Have you checked to see if your hashed signature has anything to do with this? The invalid authentication values could be tied to that.  

Member
Posts: 9
Registered: ‎06-10-2019

Re: Constantly receiving 200 error messages fron conneting my Sandbox to WooCommerce

I wouldn't even know where to start with that.