Reply
Contributor
Posts: 39
Registered: ‎04-18-2011

CreateCustomerPaymentProfile is not validating on CIM

I am just finishing up a PHP implementation of a credit card processing app using the CIM Soap based service. I've already used the test server to test basic creation of profiles, payment profiles and addresses and wanted to try throwing and properly handling failures on new payment profile validations.

 

I tried creating a new payment profile under an existing customer profile using completely wrong information - wrong billto address details, wrong expiration date and wrong CVV code. It accepted. I verified the validationMode was set to 'liveMode' and tried it again, same result.
So I switched it to the live server with the live credentials and it did the same thing.

 

I thought the CreateCustomerPaymentProfile was supposed to verify the card details when creating a new profile with validationMode set to liveMode? Am I missing something???

 

SW

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: CreateCustomerPaymentProfile is not validating on CIM

Did you check the AVS, CVV response from it? If the issuing bank allow it, then you can use those response to reject it.

Contributor
Posts: 39
Registered: ‎04-18-2011

Re: CreateCustomerPaymentProfile is not validating on CIM

OK, the AVS Response will give me details on the address check, but the Card Code response is coming back as 'P' (not processed) and neither of those seem to tell me anything about why the expiration date is not being validated?

 

SW

Posts: 2,765
Topics: 57
Kudos: 251
Blog Posts: 67
Registered: ‎12-05-2011

Re: CreateCustomerPaymentProfile is not validating on CIM

The sandbox only simulates a connection to a processor, so no actual validation is performed.  If you wish to test responses to specific error conditions, please use the error generation guide.

 

Richard