Reply
Highlighted
Member
Posts: 7
Registered: ‎11-05-2013

DPM Relay URL Not Working

Hi There,

 

I'm having issue with DPM relay url with error:

 

An error occurred while trying to report this transaction to the merchant. An e-mail has been sent to the merchant informing them of the error. The following is the result of the attempt to charge your credit card.

      This transaction has been approved.

It is advisable for you to contact the merchant to verify that you will receive the product or service.

 

The URL worked perfectly fine in Sandbox mode but when we switch it to Live, we can't make it to work regardless of what URL we add in Response/Receipt URLs under Account Settings. Here's the pattern I added to Response/Receipt URLs:

 

https://www.domain.com - Default Response

https://www.domain.com - Default Receipt

http://domain.com

https://domain.com

http://www.domain.com

 

I think that should cover all patterns. Our sandbox runs on a subdomain using http:// but our live runs on the main domain with https:// but I don't think that should be an issue. And both sandbox and live site are running on the same server but different installation with identical code. Unless, I am wrong, please do correct me.

 

I had this issue when I was early on the developer on sandbox mode but I quickly learned to add the URL in the account settings and the error will quickly disappear. But this time on live mode, it's a pain! Is there something that I can do to trace further what's going on? I don't get any error in apache log, nor in any log in the server. I wish Authorize.net will spit more descriptive error than "An error has occured...". What's happening is it instantly show that error and if I go to the Relay URL code and try to print something just to see if it really relayed back, I don't see anything... nothing. So, what does it say? The relay did not happen. I already tried this:

 

https://developer.authorize.net/tools/paramdump/index.php

 I got all the required variables and yes, x_relay_url is 100% the right one. And if I manually run the URL, the print code I inserted will spit out something.

 

Anybody have an answer to this? Any help?

 

Thanks!

Highlighted
Posts: 2,765
Topics: 57
Kudos: 247
Blog Posts: 67
Registered: ‎12-05-2011

Re: DPM Relay URL Not Working