Reply
Highlighted
Contributor
Posts: 10
Registered: ‎06-28-2014

DPM valid card expiration date fails with "card has expired"

Certain valid expiration dates entered posted from my DPM test form fail against my sandbox account with a "card has expired" message. This is a sporadic problem and I'm not quite sure what's triggering it. As you can see, I'm using on of the test MC numbers.

 

Here's the sample payment form data posted:

 

x_first_name: Joe

x_last_name: Customer

x_card_num: 5555 5555 5555 4444

x_exp_date: 01/15

x_card_code: 123

 

Here's log output for the error:

 

The transaction was declined: credit card MasterCard XXXX4444, Authorize.net CC order with auth code: (subcode: 8, avscode: P). The credit card has expired.

 

I've used the parameter dump tool to check the values I'm posting, and the payment details posted look fine. I was originally posting the expiration date as MM / YY (spaces around the slash). I've since started to remove all spaces.

 

As I said, this is sporadic. I think I've been able to submit some other combination with the date 01/15 and the sandbox gateway processes the test successfully. This happens with each test card number (Visa, MC, Amex, etc.).

 

 

 

 

 

 

 

 

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: DPM valid card expiration date fails with "card has expired"

I think I've been able to submit some other combination with the date 01/15 and the sandbox gateway processes the test successfully.

 

So, some combination always fail, and some combination always success?

Highlighted
Contributor
Posts: 10
Registered: ‎06-28-2014

Re: DPM valid card expiration date fails with "card has expired"

Close, but not always. I haven't pinned down exactly the combination that always fails, but I can say that some combinations with the date 12/15, always succeed.

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: DPM valid card expiration date fails with "card has expired"

Works when the month is double digit?

Highlighted
Contributor
Posts: 10
Registered: ‎06-28-2014

Re: DPM valid card expiration date fails with "card has expired"

12/15 seems to work every time. 10/15 has failed from time to time.

Highlighted
Contributor
Posts: 10
Registered: ‎06-28-2014

Re: DPM valid card expiration date fails with "card has expired"

I've systematically gone through and tested MC with each month, starting with the current 11/14 through 01/16. The trend is pretty clear, with the exception of 09/15. So, I'm stripping the leading zero from the expiration date prior to submit. We'll see.

 

01/15 failed initially. Subsequent submission succeeds.

02/15 failed every attempt

03/15 failed every attempt

04/15 failed every attempt

05/15 failed every attempt

06/15 failed every attempt

07/15 failed every attempt

08/15 failed every attempt

09/15 succeeds

10/15 succeeds

11/15 succeeds

12/15 succeeds

01/16 failed every attempt

 

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: DPM valid card expiration date fails with "card has expired"

I'm stripping the leading zero from the expiration date prior to submit.

I think it need the leading zero.

Highlighted
Contributor
Posts: 10
Registered: ‎06-28-2014

Re: DPM valid card expiration date fails with "card has expired"

After seeing that almost all dates with leadings zeros fail, I've begun stripping them and it seems to have fixed my problem, at least when operating against my sandbox account.

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: DPM valid card expiration date fails with "card has expired"

Can you remove the "/"

 

e.g. just do 0115, 0915, 1215, etc