Reply
Member
Posts: 1
Registered: ‎09-25-2019

E00007 auth failed, in prod mode, correct credentials

[ Edited ]

So I'm using the node sdk.

 

I've double checked the credentials.

 

I'm creating a customer profile.

 

The same thing worked in test mode.

 

Other api functionality is working for me in production. But not creating a customer profile.

 

Here is the request from the node sdk before sending.

 

{
  "createCustomerProfileRequest": {
    "merchantAuthentication": {
      "name": "CORRECT_NAME",
      "transactionKey": "CORRECT_KEY"
    },
    "clientId": null,
    "profile": {
      "merchantCustomerId": "M_TgULjXOKCwx",
      "email": "myemail@yahoo.com",
      "paymentProfiles": [
        {
          "customerType": "individual",
          "payment": {
            "opaqueData": {
              "dataDescriptor": "COMMON.ACCEPT.INAPP.PAYMENT",
              "dataValue": "someToken_alkdsjafjsdf"
            }
          }
        }
      ]
    }
  }
}

 

 I was hoping somebody would see something here that I'm not seeing. Or point me in the right direction. Thanks. 

Highlighted
Member
Posts: 2
Registered: ‎09-25-2019

Top Digital Marketing Services

Orange Global is a Delhi based Registered Company, having branches and franchises in Delhi, Noida, Ghaziabad, and Lucknow. We provide turnkey solution for Web Consulting, Digital Marketing, Content Development, and Branding and Consulting. Our team contains expert professionals who are highly experienced in their respective domain.

 

Top Digital Marketing Services