Reply
Member
Posts: 6
Registered: ‎12-23-2016

Re: E00040 when Creating Subscription from Customer Profile

Hello Aaron,

 

Thanks for your response. Yes, as mentioned in the very first message of this thread, at least a 15 second delay is required between the request for Authorize to create a Customer Profile, and the next request to create a Subscription. We believe that such a long delay is unacceptable, and the root cause should be determined and corrected.

 

I would also be very interested, for my own edification, to see what you had to remove from my post that you labeled "spam." It was definately not placed there intentionally. Please send to me directly at ralphgriffith59@gmail.com. And, no, I don't mind sharing my email address.

 

Best Regards,

 

Ralph Griffith

All Star
Posts: 699
Registered: ‎11-03-2016

Re: E00040 when Creating Subscription from Customer Profile

Hi Ralph,

 

No worries about your post. The post with the spam links was by user @kankikara. That's the user I was replying to.

Member
Posts: 6
Registered: ‎07-29-2015

Re: E00040 when Creating Subscription from Customer Profile

Hi All -

 

I am having the same problem. 

 

My app processes normal CNP transactions that might include orders for recurring billing items (subscription) and also optionally need to save card info (if selected by the customer).  And I'm trying to implement accept.js.  Everything works fine if I send the card data to the server and run these (up to 3) API calls passing card info (not using Accept.js).

 

So to use accept.js where token can only be used once, I had to restructure to:

1. create customer profile (createCustomerPaymentProfileRequest),

2. charge card for initial subscription period (createCustomerProfileTransactionRequest)

3. create subscription (ARBCreateSubscriptionRequest)

 

In sandbox, 1 and 2 report success, and 3 returns record not found.  I will try putting in a 15 sec delay on the last step if Sandbox.

 

But do we know yet if this delay is required for production?  That will not be acceptable in a production setting.

 

Thanks,

KR

 

 

 

Member
Posts: 1
Registered: ‎05-09-2018

Re: E00040 when Creating Subscription from Customer Profile

I'm very interested in doing exactly what you're trying to do worldmodern. Could you possibly show your code to create a profile and a subscription from accept.js? I'd be more than happy to try my hand at removing the 15 second sleep.

Member
Posts: 2
Registered: ‎03-01-2021

Re: E00040 when Creating Subscription from Customer Profile

This thread is from 2018 and it seems that this issue is still there in Auth.net Production API endpoint. We have multiple instances of the same issue for different clients who have been using Aith.net. Does anyone know if this has been addressed as part of any patch or release? 

Member
Posts: 1
Registered: ‎03-02-2021

Re: E00040 when Creating Subscription from Customer Profile

SAAD ASHRAF is a freelance web designer working for his clients from around the world.