Reply
Member
Posts: 3
Registered: ‎02-11-2014

Error 87, Works in test environment, doesn't work on live.

I can't figure this out...

 

array
(
    'ResponseCode' => '3'
    'Errors' => array
    (
        'Error' => array
        (
            'ErrorCode' => '87'
            'ErrorText' => 'Transactions of this market type cannot be processed on this system.'
        )
    )
    'AuthCode' => '000000'
    'AVSResultCode' => 'P'
    'CVVResultCode' => array()
    'TransID' => '0'
    'RefTransID' => array()
    'TransHash' => '4D598250AEC3CBE87C21737CD6919126'
    'TestMode' => '1'
    'UserRef' => array()
    'AccountNumber' => array()
    'AccountType' => array()
    '@root' => 'response'
)

 

 

I keep getting this error 87. The market type is ecommerce...we have tried all values from 0 - 5. Nothing works. One other thing we can't find (not sure if it's necessary) is how to pass the SIC code. In the authorize.net hep docs it mentioned that we were passing the wrong value?

 

Any help would be appreciated.

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Error 87, Works in test environment, doesn't work on live.

ecommerce shouldn't be using a Card Present account. Did they got the wrong type?

Or are you doing a Card Present transaction on a Card NOT Present Live account?

Member
Posts: 3
Registered: ‎02-11-2014

Re: Error 87, Works in test environment, doesn't work on live.

The account says it's a card not present account.

 

 
Product Type:Card Not Present
Product Description:medical services to facilities
Market Type:eCommerce
Member
Posts: 3
Registered: ‎02-11-2014

Re: Error 87, Works in test environment, doesn't work on live.

What is the market type value we pass? CP / retail is 2, so what is ecommerce?

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Error 87, Works in test environment, doesn't work on live.

[ Edited ]

If it is a Card Not Present account, you don't pass market type as it is only for Card Present API.

 

Maybe you got the wrong type on your test account?

Posts: 2,765
Topics: 57
Kudos: 248
Blog Posts: 67
Registered: ‎12-05-2011

Re: Error 87, Works in test environment, doesn't work on live.

[ Edited ]

Hello sdiggles:

 

I would recommend sending a support request http://developer.authorize.net/support.  Please be certain to include your gateway ID.

 

Richard