Reply
Member
Posts: 2
Registered: ‎07-10-2013

Error connecting to AuthorizeNet using AIM

Last year, my organization used Auth.net to process payments for an event. This year, they want to do the same. Last year, the implementation of AIM checkout worked without a problem. Since then, however, they have hired me and have moved to a new server. Now the AIM scripts don't work.

 

Whatever I do, I get this "error" (without any error codes or response codes):

 

Error connecting to AuthorizeNet

 

I have looked at the SDK and pinpointed the issue down to the _sendRequest() protected function in lib/shared/ in the SDK. I'm thinking something is going on weird with cURL, but I'm not sure what. When I tried switching the cURL url to an http address, the script worked and did not return an error. However, when I used any https url, it returned the error.

 

I'm assuming this is an issue with cURL wanting to authenticate the SSL certificates. I tried setting $VERIFY_PEER to false (on line 14) to no avail. I tried manually setting CURLOPT_SSL_VERIFYPEER and CURLOPT_SSL_VERIFYHOST to either false or 0, again to no avail.

 

I even decided to start from scratch and download the SDK and use the sample code, but that didn't even work.

 

Both PHP and cURL are up-to-date, so that's not the issue. Does anyone have any ideas?

 

Thanks!

Member
Posts: 2
Registered: ‎07-10-2013

Re: Error connecting to AuthorizeNet using AIM

To clarify:

 

The path to the file I was mentioning is in fact:

lib/shared/AuthorizeNetRequest.php

 


Posts: 1,609
Topics: 15
Kudos: 200
Solutions: 121
Registered: ‎06-23-2011

Re: Error connecting to AuthorizeNet using AIM

There are a variety of things that could cause this. What do you get for output you use CURLOPT_VERBOSE?

 

Just one example of weird fixes that might be required:

http://matt.thomm.es/archive/2012/10/26/php-curl-error-ssl-connect-error