Reply
Contributor
Posts: 18
Registered: ‎11-09-2017
Accepted Solution

Error connecting to AuthorizeNet

All ... sorry if this is covered somewhere else ...my searching didn't turn up anything recent.

 

On 4/30 at 3:30am CT "sercure.authorize.net" stopped accpeting our connections.  After contacting Authorize support they acknowledged that they had broken "SSL" on that connection and asked that we use "secure2.authorize.net".  Unfourtunatly, that is not working for us.  

 

I have a support ticket open:

Case: 05030156 - All CC Connection Attempts Being Rejected

 

We have tried ...

  1. We have put all new certs on our site 
  2. We have tried going to secure2.authorize.net vs. secure.authorize.net  
  3. We have added their info to a “safe site” list in Apache 

Nothing ... anyone else having this issue?

 


Accepted Solutions
Solution
Accepted by topic author matterickson7
‎05-01-2018 10:53 AM
Contributor
Posts: 18
Registered: ‎11-09-2017

Re: Error connecting to AuthorizeNet

All ... this was fast ...

 

We did update the certs ... that wasn't it.

 

Two issues for us ...

 

1. We had missed a reference to secure.authorize.net in our code ... fixed that ...

2. The reposnse data was different ... "HTTP/1.0 200 OK" started coming over ... instead of "HTTP/1.1 200 OK". 

 

 

View solution in original post


All Replies
Member
Posts: 3
Registered: ‎05-01-2018

Re: Error connecting to AuthorizeNet

Solution
Accepted by topic author matterickson7
‎05-01-2018 10:53 AM
Contributor
Posts: 18
Registered: ‎11-09-2017

Re: Error connecting to AuthorizeNet

All ... this was fast ...

 

We did update the certs ... that wasn't it.

 

Two issues for us ...

 

1. We had missed a reference to secure.authorize.net in our code ... fixed that ...

2. The reposnse data was different ... "HTTP/1.0 200 OK" started coming over ... instead of "HTTP/1.1 200 OK". 

 

 

Member
Posts: 3
Registered: ‎04-01-2015

Re: Error connecting to AuthorizeNet

Has anyone successfully been able to connect to test.authorize.net? I'm having the same issue there as well. moving to secure2.authorize.net fixed production though thankfully

Member
Posts: 7
Registered: ‎01-29-2018

Re: Error connecting to AuthorizeNet

Changing the endpoint to secure2.authorize.net did nothing for us.  That may all depend on which version of the SDK you have.  We are running an older one that supports PHP versions 5.3.

 

The thread for the cert replacement is what fixed it for us: https://community.developer.authorize.net/t5/Integration-and-Testing/Cert-pem-expired-Why-Why-Why/td...

 

Check it out.

Member
Posts: 1
Registered: ‎05-29-2020

Re: Error connecting to AuthorizeNet

[ Edited ]

All of sudden I statrted getting this error. Is anybody having the same issue? I have tried changing the API keys as well. That didnot help. Kindly assist.

Member
Posts: 1
Registered: ‎06-03-2020

Re: Error connecting to AuthorizeNet

Same issue here, thought it was a Mikrotik or Cert issue but still no luck...

[Followup]

So I managed to fix it in our case by removing and adding them back on our Mikrotik

/ip hotspot walled-garden ip
add action=accept comment=js.authorize.net disabled=no dst-host=\
    js.authorize.net
add action=accept comment=api.authorize.net disabled=no dst-host=\
    api.authorize.net
add action=accept comment=crl.entrust.net disabled=no dst-host=crl.entrust.net
add action=accept comment=secure2.authorize.net disabled=no dst-host=secure2.authorize.net 
add action=accept comment=authorize-accept.authorize.net disabled=no dst-host=\
    accept.authorize.net

Hope this helps someone else

Highlighted
Member
Posts: 2
Registered: ‎08-27-2021

Re: Error connecting to AuthorizeNet

Facing the same issue any solution, please.