Reply
Highlighted
Member
Posts: 2
Registered: ‎09-16-2010

Error w/processing transacion — Please Help

Recently out of the blue (I didn't make any changes) my customers have been getting this error message when submitting their info:

 

(97) This transaction cannot be accepted.

 

So I went on the chat ant they told me to enter my x_fp_timestamp on this website: http://developer.authorize.net/tools/responsecode97/

 

Anyway I went into my php (SIM) code and this is all I have for the variable:  

$sequence=time();
$tstamp=time();

 

There's no numbers to put in or anything. I guess I'm really confused as to what to put into the request form and in general why I would just get this error out of the blue?

 

Any feedback/help/assistance would be greatly appreciated.

 

Thanks

 

 

 

Highlighted
Contributor
Posts: 13
Registered: ‎09-14-2010

Re: Error w/processing transaction — Please Help

for reference this is what response code 97 means:

 

Applicable only to SIM API. Fingerprints are only valid for a short period of time. If the fingerprint is more than one hour old or more than 15 minutes into the future, it will be rejected. This code indicates that the transaction fingerprint has expired.

 

I cannot say for sure but check the timezone of your server VS the timezone you have setup in your authorize.net account settings. All I can think is that there may be some conflict between them in timezones that is making the transaction fingerprint look like it is more than an hour old. This could have happened out of the blue if you have changed servers, if your hosting company changed the location of your server for you or if another site on the server changed the PHP.ini file to be set to the new timezone.

 

As a potential fix if this is in fact the issue add the timezone definition to your php.ini file to match that of your authorize.net account. (both of which should be set to your primary office's local time.)

 

php.ini setting would look something like

 

 

date.timezone = "US/Central" 

 

 

Highlighted
Member
Posts: 2
Registered: ‎09-16-2010

Re: Error w/processing transaction — Please Help

Thanks for the response...

 

Hmmm both autorize.net and my server are set to CST... yet I'm still getting the 97 error...

I literally changed nothing in the time that this started happening. This is making me go crazy!

 

Anymore help would be greatly appreciated.

 

Highlighted
Trusted Contributor
Posts: 451
Registered: ‎08-21-2009

Re: Error w/processing transaction — Please Help

Authorize.Net server sync to GMT. You should either sync yours to GMT as well or include code that will adjust the timestamp accordingly.

 

 

Thanks,

Elaine

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Error w/processing transaction — Please Help

Check to see if the TimeZone setting got changed.

Login to the testsite https://test.authorize.net or productionsite https://account.authorize.net/

Account - Settings - Business Settings - TimeZone

It probably need administrator to see/change it.

Highlighted
Member
Posts: 2
Registered: ‎11-09-2011

Re: Error w/processing transaction — Please Help

Robert B at authorize.net chat says:

Robert B:  Yes, our tech's agree the Time Zone setting will not effect that error you are getting.

 

So the info above from RaynorC1emen7 is incorrect. 

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Error w/processing transaction — Please Help

Yep that is incorrect. Sample code do show how to get the correct value.