Reply
Highlighted
Member
Posts: 1
Registered: ‎08-24-2015

Error with relay response

Hi

 

We are non-profit org and have been using Authorize.net's SIM for accepting donations on our website. We have had no issues with this process for the last three years. But in the last 2-3 weeks, we are receiving complaints from our users that they see an error on their screen after submitting payment.

Here's the error:

 

An error occurred while trying to report this transaction to the merchant. An e-mail has been sent to the merchant informing them of the error. The following is the result of the attempt to charge your credit card.

      This transaction has been approved.

It is advisable for you to contact the merchant to verify that you will receive the product or service.

 

Apparantly transaction goes thru just fine but Authorize.net fails to post the transaction info back to our website url sepcified in the x_relay_url parameter. We haven't made any code changes for this to happen. When I spoke to the customer support they suggested I should try changing the transaction key which I did and the issue remains the same.

 

Here's the html code:

   <FORM id="paymentForm" METHOD=POST ACTION="https://secure.authorize.net/gateway/transact.dll" target="_self">

    - - -

    - - -

        <INPUT TYPE=HIDDEN NAME="x_relay_response" VALUE="true">
        <INPUT TYPE=HIDDEN NAME="x_relay_url" VALUE="https://secure.svlotustemple.org/puja/relay.asp">
   </FORM> 

 

Any assistance is greatly appreciated.

 

Thanks

RC

 

Member
Posts: 3
Registered: ‎08-22-2015

Re: Error with relay response

Is it possible that there were changes made to the actual server settings? I had a similar issue with DPM whenever I disabled TLS v 1.0.