Reply
Highlighted
Contributor
Posts: 12
Registered: ‎09-15-2014

Getting response reason code as RRC_0_0 in PROD

Hi,

We have recently moved to prod and after success AUTH only using SIM and when we tried to do AIM with prior auth capture it is giving RRC_0_0.

 

We are stuck up here, can some body help ASAP.

 

Merchant merchant = Merchant.createMerchant( Environment.PRODUCTION, apiLoginID,
transactionKey);

// PRIOR AUTH CAPTURE
Transaction authCaptureTransaction = merchant.createAIMTransaction(TransactionType.PRIOR_AUTH_CAPTURE, amount);
authCaptureTransaction.setTransactionId(transactionId);
Result<Transaction> result = (Result<Transaction>) merchant.postTransaction(authCaptureTransaction);

 

When I try to run from my local it is working perfectly.

 

 

Thanks,

Chandra

 

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Getting response reason code as RRC_0_0 in PROD

[ Edited ]

When you run on local, it is using the production account?

Sound like is is not getting result, url is wrong(or getting block), or it not in the right format(e.g. it a card present account)

Highlighted
Contributor
Posts: 12
Registered: ‎09-15-2014

Re: Getting response reason code as RRC_0_0 in PROD

Yes, In local when I tried to use production account, it was successful.

 

And I am using SIM for AUTH ONLY which was successful, and PRIOR_AUTH_CAPTURE using AIM which is giving RRC_0_0. (IN PRODUCTION)

 

Thanks,

Chandra

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Getting response reason code as RRC_0_0 in PROD

If the production account work on your local. and the code is the same as production server. then

Have you check the url? maybe it getting block? SIM and AIM do use different URL.