Reply
Highlighted
Member
Posts: 6
Registered: ‎09-04-2014
Accepted Solution

HTTPS filter and silent post response

I am registering global filter RequireHttpsAttribute() in my MVC application for credit card payment wizard. It is a recurring process and silent post response is enabled & supposed to be received. Please tell that can this filter cause any issue for silent response? as previously this filter was not registered and silent response was coming successfully.


Accepted Solutions
Highlighted
Solution
Accepted by topic author osamarizwan
‎08-21-2015 01:58 AM
Member
Posts: 6
Registered: ‎09-04-2014

Re: HTTPS filter and silent post response

Thanks for replying, i found it helpful. Now silent response is receiving (there was some exception in code which prevented method execution).

View solution in original post


All Replies
Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: HTTPS filter and silent post response

If you regsiter the filter and break it, then yeah, that probably it.

Did you register the silent post URL on the merchant account with HTTPS ?

Highlighted
Member
Posts: 6
Registered: ‎09-04-2014

Re: HTTPS filter and silent post response

Yes I am registering with https, now I think silent post response shoulld come as previous and filter should not block it, correct me if I am wrong.

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: HTTPS filter and silent post response

[ Edited ]

You might have to check the http log, I think when authorize.net post to your url and it is not getting http status 200, it will not post any response.

Highlighted
Solution
Accepted by topic author osamarizwan
‎08-21-2015 01:58 AM
Member
Posts: 6
Registered: ‎09-04-2014

Re: HTTPS filter and silent post response

Thanks for replying, i found it helpful. Now silent response is receiving (there was some exception in code which prevented method execution).