Reply
Highlighted
Contributor
Posts: 13
Registered: ‎04-20-2018

Haven't received webhook notifications in 2 hours

[ Edited ]

I am integrating webhook integrations into something that I am building. I am testing using Postman, and everything was working fine until a couple of hours ago...where now it seems that new transactions (that show up in Authorize.net) are not showing up as of the last 2 hours or so. I still see notifications from before that...but any new transactions sent to Authorize.net don't seem to be sending out notifications. It might help to know that I am currently using the Sandbox.

 

Is there some kind of limit or time cut-off for webhook notifications? Or, is something broken on your guys' end. I don't think it's something I did wrong because new notifications aren't coming in for both my site (that I am integrating) and Postman (from which I am using for reference and testing). Please help. Thank you!

Highlighted
Contributor
Posts: 13
Registered: ‎04-20-2018

Re: Haven't received webhook notifications in 2 hours

NEW DEVELOPMENT:

 

If I change the GET url from:

https://apitest.authorize.net/rest/v1/notifications/

 

To:

https://apitest.authorize.net/rest/v1/notifications?limit=51&from_date=3/30/2018

 

I get the new notfications. Any idea why? I didn't have to do that before.

Highlighted
Contributor
Posts: 13
Registered: ‎04-20-2018

Re: Haven't received webhook notifications in 2 hours

I am still having the same problem. Is there anyone that can help?

Highlighted
All Star
Posts: 727
Registered: ‎11-05-2018

Re: Haven't received webhook notifications in 2 hours

Hey jonCherlin1, 

 

I think your second example is working because you are passing parameters. Your first example is not. I would imagine that any notification request would have to pass some sort of parameter(s).