Reply
Highlighted
Member
Posts: 1
Registered: ‎01-16-2019

Having issues connectiong to authorize.net

after downloading the sdk through composer(PHP) and doing the neccessary things, I run nto this problem

 

Fatal error: Declaration of JMS\Serializer\JsonDeserializationVisitor::startVisitingObject(JMS\Serializer\Metadata\ClassMetadata $metadata, JMS\Serializer\object $object, array $type): void must be compatible with JMS\Serializer\Visitor\DeserializationVisitorInterface::startVisitingObject(JMS\Serializer\Metadata\ClassMetadata $metadata, JMS\Serializer\Visitor\object $data, array $type): void in /home/vagrant/Code/Project/vendor/jms/serializer/src/JsonDeserializationVisitor.php on line 14

What does it mean and how can I solve the problem

Highlighted
Authorize.Net Expert
Posts: 75
Registered: ‎07-27-2016

Re: Having issues connectiong to authorize.net

Hi @walegbengasupo8

 

Please provide us with more details on the version of PHP-SDK you are using.

 

Did you do a fresh setup with composer or did you upgrade your setup from previous version of sdk to the current one ?

 

Also sharing the OS and PHP version information would help us while looking into this issue.

 

Kaushik