Integration and Testing

Authorize.Net API questions and help with your payment integration.

Reply
Contributor
Posts: 13
Registered: ‎09-25-2012

Re: Iframe or Hosted Redirect - invalid or missing token

I suppose I could try it. It seemed like there was quite a bit of extra fluff in it and I just wanted to strip it down to the basics. But at this point I'm willing to give anything a try. I'll post back later :) Thanks for all the suggestions.

Solution
Accepted by topic author Fundamental
‎08-21-2015 01:58 AM
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Iframe or Hosted Redirect - invalid or missing token

Now that I'm awake. the problem is that the <form /> is not posting anything, it doesn't have a button, there is no javascript that post the form. So basically, you are just try to open https://test.authorize.net/profile/manage on a iframe which will fail because it not getting any token. Download the sample code and see how it work and change it to work with php.

Contributor
Posts: 13
Registered: ‎09-25-2012

Re: Iframe or Hosted Redirect - invalid or missing token

It had to be the button since as far as I could see, the js file simply managed the behavior of the popup. However, since I do like the way it makes the popup look I might just keep it. However I'm now getting a new error message: CIM is not enabled, but I'm using the sandbox and everything should be enabled, am I right? At least I'm getting a different error message! I'll doublecheck the API login info.

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Iframe or Hosted Redirect - invalid or missing token

There is a line in the examplePage.html

// Uncomment this line to use test.authorize.net instead of secure.authorize.net.
//AuthorizeNetPopup.options.useTestEnvironment = true;

Contributor
Posts: 13
Registered: ‎09-25-2012

Re: Iframe or Hosted Redirect - invalid or missing token

For some reason it just wasn't working in the sandbox, with or without the test account enabled. I did use the "real" account credentials and that worked just fine. Thanks for working with me on this!!