Integration and Testing

Authorize.Net API questions and help with your payment integration.

Reply
New Member
Posts: 2
Registered: ‎01-04-2022

Incorrect currency application

Hello, my client is using software to automatically sync his Authorize.net transactions to QuickBooks Online. However, all of his transactions are synced in USD. He contacted Authorize.net Support and they said he got only one currency [CAD] enabled in his account. However, as we see on our end, the code contains 2 currencies. He also uses Elavon as a payment processor

 

"isTestMode": false,
"processors": [
{
"name": "Elavon",
"id": 1,
"cardTypes": [
"C",
"D",
"J",
"M",
"V"
]
}
],
"merchantName": [REDACTED],
"gatewayId": [REDACTED],
"marketTypes": [
"eCommerce"
],
"productCodes": [
"CNP"
],
"paymentMethods": [
"DinersClub",
"Discover",
"JCB",
"MasterCard",
"Visa"
],
"currencies": [
"USD",
"CAD"
],

 

Member
Posts: 10
Registered: ‎12-07-2021

Re: Incorrect currency application

I am having the same issue.

Member
Posts: 10
Registered: ‎12-07-2021

Re: Incorrect currency application

@Georgewright did you get any solution 

Highlighted
New Member
Posts: 2
Registered: ‎01-04-2022

Re: Incorrect currency application

@emmawilson

no, unfortunately, they still import in USD

Member
Posts: 10
Registered: ‎12-07-2021

Re: Incorrect currency application

@Georgewright thank you for your response.

Member
Posts: 10
Registered: ‎12-07-2021

Re: Incorrect currency application

@Georgewright 

thank you for the info