Posts: 2
Registered: ‎12-17-2016

Installing iOS SDK

Hello, I'm trying to install the iOS sdk and I've tried it two ways, manually, and using cocoapods.  Both ways I got an error and don't know how to fix it.




With cocoapods I got a few errors that I was able to fix such as running on device instead of simulator, disabling bitcode, /bin/sh wasn't found so I had to enable a script, during compilation, Xcode was accessing a directory and then making it.  Now I got stuck with an error I don't know how to fix.


dyld: Library not loaded: @rpath/AnetEMVSdk.framework/AnetEMVSdk
  Referenced from: /var/containers/Bundle/Application/7F308202-F101-408B-B932-BAB7E452FD72/Swipity Swipe
  Reason: image not found

I don't know how to fix this one and would appreciate someone's help.



Thanks in advance!


Posts: 2,765
Topics: 57
Kudos: 251
Blog Posts: 67
Registered: ‎12-05-2011

Re: Installing iOS SDK

Hello @macstation


Did you follow the Read.Me instructions to include the AnetEMVSDK framework into your application?



Posts: 2
Registered: ‎12-17-2016

Re: Installing iOS SDK

I tried it a few times and every time I got a bunch of errors, but I tried it again and it worked, I have no idea what I did differently though.  Thanks for your help though!