Reply
Member
Posts: 2
Registered: ‎03-23-2011

Issue with OsCommerce and Authorize.net SIM module

I've pretty much come to the end of the road of a very long website development project built on OsCommerce. I decided to use this cart since it had all of the features I needed for my project and it was open source. At the moment the entire site and all of the products are ready to go but I keep getting an error when I return from the Authorize.net SIM form. I've check this in test and live mode within Authorize.net with the same results everytime. Authorize.net is getting the payment thats made but when the ok button is clicked on the SIM form it returns back to my site with an error message displayed and the address of the Authorize.net transaction service in the URL bar.

 

These are the steps that make the bug happen.

 

The following steps take place within OsCommerce Cart (My Store)

1. Press checkout once all of the items I want are in the cart.

2. Select my delivery information and then press continue.

3. Select my payment method which is Authorize.net and then press continue.

4. Next the order confirmation page is displayed. I press Confirm order button.

The following steps take place on the Authorize.net SIM form.

5. The URL bar now list https://secure.authorize.net/gateway/transact.dll as the URL
6. All of the shipping and billing information entered in the previous area are carried over.

7. I enter in a test credit card number then press submit.
The following steps take place within OsCommerce Cart (My Store)

8. The URL bar still list https://secure.authorize.net/gateway/transact.dll but the page being displayed is the payment information page referenced in step 3. 

9.The following error message is display on the top portion of my page:

 

"There has been an error processing your credit card

The credit card transaction could not be verified with this order. Please try again and if problems persist, please try another payment method.

 

10. Pressing the continue button makes the page reload and display this alert message:

 

"Although this page is encrypted, the information you have entered is to be sent over an unencrypted connection and could easily be read by a third party.

Are you sure you want to continue sending this information?"

 

10. Pressing continue on this alert takes you back to the order confirmation screen reference in step 4.

 

11. The same process will just repeat over and over from this point.

 

 

Authorize.net does logg the transaction when its not in test mode so I know the buy is being recorded and the confirmation email is sent from Authorize.net. If anyone familiar with this can provide any help I would be very greatfull. I've read post similar to what I just posted but with less detail on the OsCommerce forums but no one seems to ever post how to fix it.

 

Thank You,

Andres

 

All Star
Posts: 1,072
Registered: ‎08-17-2009

Re: Issue with OsCommerce and Authorize.net SIM module

Hey Andres,

 

I wish we could be of more help to you, but what you're describing seems to be an issue with OsCommerce and not Authorize.Net. You said you've tried their forums, but what about their customer support or something like that? If they have that available, that may be the best thing to try.

 

Because your issue is so specialized, there may not be anyone on this community who can help. But if someone else does have an idea, maybe they'll post to this thread. I'd suggest subscribing to this thread so that if someone does respond with feedback, you'll be notified via email. To subscribe, click Topic Options at the top of this thread and then select Subscribe. You'll then receive an email once anyone replies to your post.

 

Hope you get things figured out!

 

Thanks

 

Michelle

Developer Community Manager

Member
Posts: 1
Registered: ‎06-07-2011

Re: Issue with OsCommerce and Authorize.net SIM module

I am also having this error, however it doesn't happen every time.  Most orders (that I know of) are being captured without errors.  However, some of the orders are not returned from authorize.net.  I can see the customer info in osc, the payment is captured from authorize.net, but the order information is not returned to oscommerce.  

 

Please help!

James Douglas
Online Marketing Consultant
CrowdGrip.com
Member
Posts: 3
Registered: ‎06-09-2011

Re: Issue with OsCommerce and Authorize.net SIM module

I would uninstall your module, and download the latest version Authorize.net Credit Card SIM.  Also, make sure your MySql version is up to date.

Member
Posts: 3
Registered: ‎06-09-2011

Re: Issue with OsCommerce and Authorize.net SIM module - Solution that worked for me

Set up your "Response/Receipt URLs" (thank you page),  in your Authorize.net account.

Then set your Shop url in the "Relay Response:" :smileyhappy

 

Example at http://eaglesnestcycles.com/shop/

 

This I just used it, and it worked like a a charm.

 

Good Luck.