Reply
Highlighted
Member
Posts: 5
Registered: ‎10-03-2018

Legacy Hosted CIM Service

Since September 20th, we have been unable to view the Iframe portion of the Hosted CIM service. According to authorize.net, our accounts should have been migrated.. whatever that means. This corresponds with the September 20th notice here. https://developer.authorize.net/api/changes/

 

Whenever we attempt to use an IFrame popup, we get a white screen where we used to get the forms. We do not receive any errors in the console or anywhere else. Additionally, when I view the source of the iFrame that loads from Authorize.net, everything there seems in working order. In the embedded json that is on the accept.authorize.net/customer iFrame, I can see the card number last 4 and other information.

 

We are using the endpoint:  https://accept.authorize.net/customer/

 

Anyone have any ideas on how to fix or troubleshoot this? I am at my witts end. My users have been working around it via the merchant panel, but we can't do that forever.

 

  authnet.jpg

Highlighted
Authorize.Net Expert
Posts: 75
Registered: ‎07-27-2016

Re: Legacy Hosted CIM Service

Hi @adamrandazzo

 

After Sep 20,2018  release "Users of the legacy hosted CIM  service has been migrated to Accept customer"  

 

The end points you have been using need to be changed, please use the new end point https://accept.authorize.net/customer/manage

 

 

Visit the below link to get the detailed documentation on the Hosted form integration

https://developer.authorize.net/api/reference/features/customer_profiles.html#Using_the_Accept_Custo...   

 

Kaushik