Reply
Member
Posts: 6
Registered: ‎08-21-2013

Live Mode not Validating Credit Card

With the add payment profile and add profile requests, I am setting livemode however, in the response I have the following statement: " Test transaction for ValidateCustomerPaymentProfile."

 

The credit card is not being verified. Is there any possible reasons that the livemode is not kicking in?

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Live Mode not Validating Credit Card

" Test transaction for ValidateCustomerPaymentProfile." It mean it did that validating.

Else you would get any on the response.

Member
Posts: 6
Registered: ‎08-21-2013

Re: Live Mode not Validating Credit Card

[ Edited ]

Ah okay, in that case, does this mean I would need to validate the payment profile then? Since I can pass through fake credit card numbers currently.

 

If that is the process, that seems a bit unwieldy, as I would have to add the profile, validate it, and depending on whether or not it passes, delete the profile and either continue or start over. 

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Live Mode not Validating Credit Card

The "Test transaction for ValidateCustomerPaymentProfile." description is from the auth_only transaction then void transaction to validate the credit card info. So you don't need to do it again. If you login to the merchant account you should see them on the unsettled transaction or transaction details report.

 

I pretty sure it won't create the payment profile in the livemode validation fail.

Member
Posts: 6
Registered: ‎08-21-2013

Re: Live Mode not Validating Credit Card

Firstly, thanks for the really quick responses. I greatly appreciate it.

 

If I am understanding you correctly, you are asserting that the credit card validation is indeed happening, and I should not be able to submit a fake credit card number. It should fail the validation. That being the case, let me double check my inputs and make sure that is indeed what is happening.  My understanding from the documentation is also that the validation of the card should be occur and a fake credit card profile should not be able to be added unless I am in testMode. 

 

If I still find that I am able to enter in fake numbers, then the only recourse I have is to submit a trouble ticket. Am I understanding your responses correctly?

 

 

 

 

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Live Mode not Validating Credit Card

Only if you are using fake credit card number on the production server/url. It would accept that on the test server/url.

Member
Posts: 6
Registered: ‎08-21-2013

Re: Live Mode not Validating Credit Card

[ Edited ]

Did a lot of testing, and as far as I can tell, the validity of the credit card number isn't being checked.  I don't believe it is an Account setting as the same transaction will fail via AIM.

 

What I ended up having to do is to verify the credit card via AIM with a $.01 transaction. If that passed, only then would I create a customer profile via CIM after voiding the 1 cent transaction via AIM.

 

This was quite a pain and I'll submit a trouble ticket. If anything useful comes of that I'll post their response here.

 

If anyone else is having this same problem, please post a "me too" response here. Thanks,

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Live Mode not Validating Credit Card

You might have to capture the validationDirectResponse in the CreateCustomerPaymentProfile result to see why it is.

Member
Posts: 6
Registered: ‎08-21-2013

Re: Live Mode not Validating Credit Card

I don't really see anything too useful. As part of my debugging I captured both the request and the response. Here it is with sensitive information modified. The credit number isn't as it is fake to begin with.

 

RESPONSE:

<?xml version="1.0" encoding="utf-8"?><createCustomerProfileResponse xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="AnetApi/xml/v1/schema/AnetApiSchema.xsd"><refId>VC1149179</refId><messages><resultCode>Ok</resultCode><message><code>I00001</code><text>Successful.</text></message></messages><customerProfileId>76800711</customerProfileId><customerPaymentProfileIdList><numericString>72331019</numericString></customerPaymentProfileIdList><customerShippingAddressIdList><numericString>84209066</numericString></customerShippingAddressIdList><validationDirectResponseList><string>1,1,1,This transaction has been approved.,000000,U,5481136499,none,Test transaction for ValidateCustomerPaymentProfile.,0.00,CC,auth_only,2784,John,Doe,,217 Kimberly Dr.,Norcross,GA,30092,US,678-322-8820,,chismld@live.com,,,,,,,,,0.00,0.00,0.00,FALSE,none,169803224E26B4B901318553FBAB12A1,U,,,,,,,,,,,,XXXX0005,American Express,,,,,,,,,,,,,,,,</string></validationDirectResponseList></createCustomerProfileResponse>


REQUEST:

<createCustomerProfileRequest xmlns= "AnetApi/xml/v1/schema/AnetApiSchema.xsd"><merchantAuthentication><name>2Y9Se2PiwFN</name><transactionKey>762jzB9rDcX1946v</transactionKey></merchantAuthentication><refId>VC1149179</refId><profile><merchantCustomerId>2784</merchantCustomerId><description>John Doe [VC1149179] [Guest]</description><email>chismld@live.com</email><paymentProfiles><customerType>individual</customerType><billTo><firstName>John</firstName><lastName>Doe</lastName><address>217 Kimberly Dr. </address><city>Norcross</city><state>GA</state><zip>30092</zip><country>US</country><phoneNumber>678-322-8820</phoneNumber></billTo><payment><creditCard><cardNumber>378282246310005</cardNumber><expirationDate>2014-03</expirationDate><cardCode>1234</cardCode></creditCard></payment></paymentProfiles><shipToList><firstName>John</firstName><lastName>Doe</lastName><address>217 Kimberly Dr. </address><city>Norcross</city><state>GA</state><zip>30092</zip><country>US</country><phoneNumber>678-322-8820</phoneNumber></shipToList></profile><validationMode>liveMode</validationMode></createCustomerProfileRequest>

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Live Mode not Validating Credit Card

Since, it return a transaction ID, 5481136499, I would use that info with the CIM profile info and ask them why it is happening.

 

It is just American Express card having issue?