Reply
Highlighted
Contributor
Posts: 10
Registered: ‎11-25-2014
Accepted Solution

Need help getting DPM to work

First off, I am using DPM because my understanding is that Accept.js does not support e-check and the whole reason that I am involved in making this update is to add e-check support.

 

I am trying to rewrite a classic ASP page for DPM in VB.Net using razor syntax. I have repeatedly received the error response:

 

The following errors have occurred.

(13) The merchant login ID or password is invalid or the account is inactive.

 

I know the default response. I am using the wrong login in or posting to the wrong URL. I am posting using the same URL that my current ASP page is posting to and I am using the same x_login value.

 

Also, if I go to this URL:

 

https://secure.authorize.net/gateway/transact.dll?x_version=3.1&x_type=AUTH_ONLY&x_amount=1.99&x_car... it returns that the credit card has expired. If I enter an invalid x_login on that url it returns "The merchant login ID or password is invalid or the account is inactive." If I enter my valid x_login and an invalid x_tran_key I receive "This transaction cannot be accepted."

 

So, I know that my x_login is correct and that I am posting to the correct URL.

 

In order to eliminate any coding issues, I put together a simple form just to post static information to the URL:

 

<html>
<body>
<form method="POST" action="https://secure.authorize.net/gateway/transact.dll"> 

<input type=hidden id="x_login" name="x_login" value='MY_LOGIN'/>
<input type=hidden id="x_cust_id" name="x_cust_id" value='106400289'/>
<input type=hidden id="x_card_num" name="x_card_num" value='5424000000000015'/>
<input type=hidden id="x_exp_date" name="x_exp_date" value='12-17'/>
<input type=hidden id="x_card_code" name="x_card_code" value='123'/>
<input type=hidden id="x_fp_hash" name="x_fp_hash" value='84EFB49E5F4A8F7CB3EEB3C6A1B2B305'/>
<input type=hidden id="x_amount" name="x_amount" value='123.60'/>
<input type=hidden id="x_fp_timestamp" name="x_fp_timestamp" value='1493038728'/>
<input type=hidden id="x_fp_sequence" name="x_fp_sequence" value='531'/>
<input type=hidden id="x_relay_url" name="x_relay_url" value='https://www.my.com/CCPayment2.vbhtml'/>
<input type=hidden id="x_relay_response" name="x_relay_response" value='Y'/>
<input type=hidden id="x_type" name="x_type" value='AUTH_CAPTURE'/>
<input type=hidden id="x_currency_code" name="x_currency_code" value='USD'/>
<input type=hidden id="x_version" name="x_version" value='3.1'/>
<input type=hidden id="x_invoice_num" name="x_invoice_num" value='2'/>

<input type="submit"/>
</form>
</body>
</html>

I verified that my hash value was correct using the link at:

http://developer.authorize.net/api/reference/responseCode99.html

 

This returns the error message:

(13) The merchant login ID or password is invalid or the account is inactive.

 

In researching I did find where one developer received that message because he used the same test card and amount and evidently that message is returned as the result of a duplicate. So I changed the amount, the card, the time stapm, and the hash and tried again with the same result. I also used both the "name" and "id" within the hiddden fields since I have seen references to both of those.

 

I would appreciate any help that anyone can provide. If I can't see any light on this issue by the end of the day I am not going to have a choice but to look at using a different processor. I am up against time and even though I will have to change a number of internal processes to switch to another processor, I am on a deadline to have e-check working by the end of the week.

 

 

 

 


Accepted Solutions
Highlighted
Solution
Accepted by topic author TonyS
‎04-25-2017 07:05 AM
Contributor
Posts: 10
Registered: ‎11-25-2014

Re: Need help getting DPM to work

0down voteaccept

In case anyone else is looking for an answer to this in the future, the message:

(13) The merchant login ID or password is invalid or the account is inactive.

evidently appears for more reasons than supplying the wrong login id or connecting to the wrong url at least as far as DPM is concerned.

In my instance, the refresh on my link "https://www.my.com/CCPayment2.vbhtml" contained an invalid URL. Once I discovered and fixed this, everything worked fine.

View solution in original post


All Replies
Highlighted
Solution
Accepted by topic author TonyS
‎04-25-2017 07:05 AM
Contributor
Posts: 10
Registered: ‎11-25-2014

Re: Need help getting DPM to work

0down voteaccept

In case anyone else is looking for an answer to this in the future, the message:

(13) The merchant login ID or password is invalid or the account is inactive.

evidently appears for more reasons than supplying the wrong login id or connecting to the wrong url at least as far as DPM is concerned.

In my instance, the refresh on my link "https://www.my.com/CCPayment2.vbhtml" contained an invalid URL. Once I discovered and fixed this, everything worked fine.