Reply
Member
Posts: 1
Registered: ‎01-23-2017

OSC v2.3.4/AIM + cpanel/WHM - Need help "replacing certificate in cert.pem file" with github from AN

Thanks in advance for any help - I rarely have to deal with SSL or this online store so I'm rusty when I have to.  I'm hoping it's a standard enough situation that the solution is simple and maybe this post can help others.

It's a custom php/mysql online store using OsCommerce v2.3.4 and the Authorize.net Advanced Integration Method (AIM) payment module Version: 2.0 (online status) API Version: 3.1.

We've accepted credit cards fine for two years and then it stopped working abrubtly last week with no change on our part.  If I "Test API Server Connection" in OSC I get:

----------------------------------
API Server Connection Test
close
Live Server:
https://secure.authorize.net/gateway/transact.dll
Failed! Please review the Verify SSL Certificate settings and try again.
Connection Time: 0.298s
----------------------------------

If I check the SSL configuration generally with online tools it validates, and the browsers like it fine and say "secure" etc.

Authorize.net live chat told me:
"Basically, the certificate in the cert.pem file expired, so it would need to be updated from that link. "

and later

"Unfortunately certificates expire. We update our domain certs, and if your solution stores CA certs, you have to keep those up to date too. Browsers do it automatically -- you update your browser, and you get any new CA certificates with it. But those browsers aren't in control of the PHP integration, which in turn means that when certificates expire, you lose the ability to process. It's a good idea to periodically check on the SDK certificates and update them so this doesn't happen."

and provided this link to a new cert.pem:

https://github.com/AuthorizeNet/sdk-php/blob/master/lib/ssl/cert.pem

I used cpanel to install a few of those 5 certificates to the store's account but it didn't help and I don't think it was the right thing to do.

I tried

find ./ -type f -name "cert.pem"

at the shell to find one but it's buried and I don't think it's relevant and replacing it with the one above didn't help.

I sort of understand the concept of this larger CA idea but I really don't know whether to use WHM or cpanel to upload (which) new certificates or where to get the right CA or if it's okay that they're "self-signed" or where this "cert.pem" if that's what needs to be replaced, or what SDK is relevant here etc...

Is this a common enough environment (WHM/cpanel + OsCommerce + AIM) that I could get some help with this?  Live chat just gave me the link to this forum and "hung up" pretty quick.

Many many many thanks in advance for anyone's time and help!

Highlighted
Posts: 2,765
Topics: 57
Kudos: 245
Blog Posts: 67
Registered: ‎12-05-2011

Re: OSC v2.3.4/AIM + cpanel/WHM - Need help "replacing certificate in cert.pem file" with

Hello @adensmore222

It's been a while since this was first posted.  You might also consider asking this question on the oscommerce forums at 

http://forums.oscommerce.com/forum/11-general-support/

 

You might also consider subscribing to this topic so that you'll be alerted via email if anyone from the community is able to respond with any comments. To subscribe, click Topic Options at the top of this thread and then select Subscribe. You'll then receive an email once anyone replies.

Thanks,

Richard