Reply
Member
Posts: 5
Registered: ‎01-27-2011
Accepted Solution

POST data in Silent Post is empty

As the title says, I have an account that is working fine in terms of creating and charging AIMs and ARBs, and a silent POST URL is configured. The logger on the silent POST is writing when basically anything happens to it. What it's currently finding is that it is being accessed with no POST data defined, every single time, even as ARBs come due. What would cause Authorize to hit the silent POST URL without actually providing any POST data?


Accepted Solutions
Solution
Accepted by topic author kcm
‎08-21-2015 01:58 AM
Member
Posts: 5
Registered: ‎01-27-2011

Re: POST data in Silent Post is empty

Typical that after puzzling over this for hours, I would stumble upon the answer 5 minutes after posting this topic.

 

For anyone who comes across this problem: Make sure your system is not redirecting the request in any way! Doing so causes it to drop the POST and you get the blank POST data mystery.

View solution in original post


All Replies
Solution
Accepted by topic author kcm
‎08-21-2015 01:58 AM
Member
Posts: 5
Registered: ‎01-27-2011

Re: POST data in Silent Post is empty

Typical that after puzzling over this for hours, I would stumble upon the answer 5 minutes after posting this topic.

 

For anyone who comes across this problem: Make sure your system is not redirecting the request in any way! Doing so causes it to drop the POST and you get the blank POST data mystery.

Highlighted
Member
Posts: 9
Registered: ‎05-10-2012

Re: POST data in Silent Post is empty

Hi,

 

I have the same issue with my Silent Post requests are sporadically empty .

 

I am using AIM to post a transaction to a buy_page and afterwards I want the user to see a thank_you_page, which is a different page. 

 

How did you solve the redirect issue?

 

Did you send an html response from the buy_page that onload will request the thank_you_page?

 

Thanks

Administrator Administrator
Administrator
Posts: 563
Registered: ‎08-03-2011

Re: POST data in Silent Post is empty

Hi mkleyzit84,

 

You indicated that you are using AIM, AIM is generally not used with Silent Post and Silent Post is definitely not used to render a real time receipt page for your customer.  To better assist you, I would recommend creating a new thread and further explaining the problem that you are encountering.

 

Thanks,
Joy