Reply
Highlighted
Member
Posts: 5
Registered: ‎02-02-2018

Payment Profile Verification Always Fails for AMEX only

[ Edited ]

Hi, 

 

I use validationMode = liveMode when creating new payment profile. With this flag Authorize.net generates $0.00 test transaction for verification purposes. It works fine for Visa, Mastercard, but fails on every AMEX card we try. Still if you try to use card data directly to authorize payment it works. It seems to be something about the transaction that authorize.net generates to verify profile.

 

Here is the request (i replaced sensitive info) that is sent to api: 

 

<?xml version="1.0" encoding="UTF-8"?>
<createCustomerPaymentProfileRequest xmlns="AnetApi/xml/v1/schema/AnetApiSchema.xsd" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
   <merchantAuthentication>
      <name>XXXXXXXXXXXX</name>
      <transactionKey>XXXXXXXXXXXXXXXX</transactionKey>
   </merchantAuthentication>
   <clientId>sdk-dotnet-1.9.3</clientId>
   <customerProfileId>XXXXXXXXX</customerProfileId>
   <paymentProfile>
      <customerType>individual</customerType>
      <billTo>
         <firstName>Oleksandr</firstName>
         <lastName>Kozlov</lastName>
         <company />
         <address>XXX XXXXXXX XXX, XX</address>
         <city>Cincinnati</city>
         <state>OH</state>
         <zip>XXXXX</zip>
         <country>US</country>
         <phoneNumber />
         <faxNumber />
         <email />
      </billTo>
      <payment>
         <creditCard>
            <cardNumber>XXXXXXXXXXXXXXX</cardNumber>
            <expirationDate>2021-11</expirationDate>
            <cardCode>XXXX</cardCode>
         </creditCard>
      </payment>
   </paymentProfile>
   <validationMode>liveMode</validationMode>
</createCustomerPaymentProfileRequest>

 

The response:

 

<?xml version="1.0" encoding="UTF-8"?>
<createCustomerPaymentProfileResponse xmlns="AnetApi/xml/v1/schema/AnetApiSchema.xsd" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
   <messages>
      <resultCode>Error</resultCode>
      <message>
         <code>E00027</code>
         <text>This transaction has been declined.</text>
      </message>
   </messages>
   <validationDirectResponse>2,2,65,This transaction has been declined.,,Y,XXXXXXXXXXX,none,Test transaction for ValidateCustomerPaymentProfile.,0.00,CC,auth_only,none,Oleksandr,Kozlov,,XXX XXXXXXx XXX, XX,Cincinnati,OH,45220,US,,,email@example.com,,,,,,,,,0.00,0.00,0.00,FALSE,none,2E13813F21D24B02301F696ACF681E16,P,,,,,,,,,,,,XXXX1008,American Express,,,,,,,,,,,,,,,,,</validationDirectResponse>
</createCustomerPaymentProfileResponse>

 

Transaction details:

https://imageshack.com/a/img923/9888/zGJZY1.jpg

https://imageshack.com/a/img924/1493/jZptaz.jpg

 

For me it doesnt look like user is entering incoerrect CCV code. Because every single verification transaction failed and there were no successful transactions for AMEX.

 

Any thoughts on this?

 

Highlighted
Member
Posts: 5
Registered: ‎02-02-2018

Re: Payment Profile Verification Always Fails for AMEX only

Update:

I was able to reproduce the issue just by going to CIM and trying to create a profile with "Perform credit card authorization before saving data" checked.

 

While chatting with support team they indicated that Card Code Status is Not Processed (P). And recommended to turn it off... Which I'm not excited to do.

 

Did anyone else experience the problem?

Highlighted
Posts: 2,765
Topics: 57
Kudos: 247
Blog Posts: 67
Registered: ‎12-05-2011

Re: Payment Profile Verification Always Fails for AMEX only

@oleksandrkozlov Are you submitting this transaction in the sandbox or production?  If sandbox, please indicate the zipcode, it can potentially trigger specific responses.

Highlighted
Member
Posts: 5
Registered: ‎02-02-2018

Re: Payment Profile Verification Always Fails for AMEX only

No, it was production environment. 

 

As a temporary solution we disabled rejection of Not Processed statuses. Analysis shown that this response occurs only when validating profile for Amex.

Highlighted
Posts: 2,765
Topics: 57
Kudos: 247
Blog Posts: 67
Registered: ‎12-05-2011

Re: Payment Profile Verification Always Fails for AMEX only

@oleksandrkozlov 

 

Because this is an issue with your production gateway, please contact customer support and open a case.  You can reach them by phone at 877-447-3938.

 

Richard

Highlighted
Member
Posts: 1
Registered: ‎07-20-2018

Re: Payment Profile Verification Always Fails for AMEX only

[ Edited ]

I am currently having the same issue, what was the solution?

Highlighted
Moderator
Posts: 102
Registered: ‎06-26-2018

Re: Payment Profile Verification Always Fails for AMEX only

Hi User007, 

 

This is likely related to your merchant account, or perhaps another account setting you have in place, but in order to know for sure you will need to follow the previous direction provided by contacting our support staff so they may review your account. 

 

Thank you,

Elaine