Reply
Highlighted
Member
Posts: 1
Registered: ‎05-26-2021

Possibly autoload.php not updated

Hello!

 

I've updated Authorize sdk-php from zip to 2.0.2 on Bluehost (I can't use Composer).

 

I'm running into this error:

 

[26-May-2021 15:50:57 UTC] PHP Fatal error:  Uncaught Error: Class 'net\authorize\util\Mapper' not found in /home3/lincomn7/public_html/wp-content/themes/medicom/sdk-php/lib/net/authorize/api/controller/base/ApiOperationBase.php:121
Stack trace:
#0 /home3/lincomn7/public_html/wp-content/themes/medicom/sdk-php/lib/net/authorize/api/controller/base/ApiOperationBase.php(104): net\authorize\api\controller\base\ApiOperationBase->execute('https://api2.au...')
#1 /home3/lincomn7/public_html/wp-content/themes/medicom/sdk-php/charge-credit-card-page.php(128): net\authorize\api\controller\base\ApiOperationBase->executeWithApiResponse('https://api2.au...')
#2 /home3/lincomn7/public_html/wp-includes/template.php(732): require('/home3/lincomn7...')
#3 /home3/lincomn7/public_html/wp-includes/template.php(676): load_template('/home3/lincomn7...', false, Array)
#4 /home3/lincomn7/public_html/wp-includes/general-template.php(204): locate_template(Array, true, false, Array)
#5 /home3/lincomn7/public_html/wp-content/themes/medicom/authorize-payment-form.php(20): get_templ in /home3/lincomn7/public_html/wp-content/themes/medicom/sdk-php/lib/net/authorize/api/controller/base/ApiOperationBase.php on line 121

I found here that this issue can be related to an outdated autoload.php.

 

Could you please help me to find a solution.

 

Thank you!