Reply
Highlighted
Member
Posts: 7
Registered: ‎11-07-2012

Problem with previously working OSCommerce installation and SIM Processing

Hello,

 

I had a previously working installation of OSCommerce working with authorize.net SIM processing. As far as I know nothing has changed. Orders stopped processing through our website. When trying to complete a transaction

on the following page https://secure.authorize.net/gateway/transact.dll, I get the error "An error occurred while trying to report this transaction to the merchant. An e-mail has been sent to the merchant informing them of the error.".

 

After discussing this in chat, they were able to point me to a page which did not provide any help. https://support.authorize.net/authkb/index?page=content&id=A663 . I do not think the transaction is timing out, since it takes less than a second after hitting the submit button to get the error back.

 

I verified that the x_relay_url hidden field on https://secure.authorize.net/gateway/transact.dll is getting properly populated and the URLs for both the reposnse/recepit URLS both load from a web browser and are accessible. I even tried changing them to other URLS which load on the website, but that did not change the error message.

 

I am not sure what my next step should be to troubleshoot why the transactions stopped working. Any help would be great.

 

Thanks,

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Problem with previously working OSCommerce installation and SIM Processing

any change to your web server?

Highlighted
Member
Posts: 7
Registered: ‎11-07-2012

Re: Problem with previously working OSCommerce installation and SIM Processing

The webserver is running on network solutions. As far as I know there was no change. I did not receive any emails saying the server had changed, but i can not rule it out... How can I test to make sure the server can accept redirects from the autorize.net server?

 

Thanks!

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Problem with previously working OSCommerce installation and SIM Processing

You can try to post data to the URL in code. For example, in php use cURL, C# with WebRequest.

Highlighted
Member
Posts: 7
Registered: ‎11-07-2012

Re: Problem with previously working OSCommerce installation and SIM Processing

I was able to post form data from a different server over to the one that is not allowing authorize.net access. It appears as if the data is getting through and the server is allowing remote servers to post data to it.

 

Thanks

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Problem with previously working OSCommerce installation and SIM Processing

Did the SSL cert got updated recently?

Highlighted
Member
Posts: 7
Registered: ‎11-07-2012

Re: Problem with previously working OSCommerce installation and SIM Processing

The website does not have a SSL associated with it. The user enters their credit card data on authorize.net for security.


Network solutions told me that it sounds like there is something on authorize.net that has blocked the netsol IP address of our website. Is this even possible?

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Problem with previously working OSCommerce installation and SIM Processing

I was able to post form data from a different server over to the one that is not allowing authorize.net access. It appears as if the data is getting through and the server is allowing remote servers to post data to it.

 

Is that a form post? and not a code web request?, a codeweb request is closer to what authorize.net is doing for relay response. One of the different is that User-Agent is blank from a code web request, while a form post will be your web browser.

Highlighted
Member
Posts: 7
Registered: ‎11-07-2012

Re: Problem with previously working OSCommerce installation and SIM Processing

Hello,

 

Originally I did just try a form post. I did just try on a different server to CURL a page with php on the remote server that authorize.net does not access. I was able to pull back data without issue.

 

Thanks,

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Problem with previously working OSCommerce installation and SIM Processing

Don't know what else to test. Maybe authorize.net can check their end to see if your ip is getting block.