Reply
Highlighted
Member
Posts: 5
Registered: ‎10-31-2017
Accepted Solution

Relay Response no longer working

Customer contacted me and told me the payment integration stopped working around January, without any changes in our part. I thought it was the md5 hash change but apparently not. Relay Response is simply not working on the site (Authorize.Net live environment).

 

I have also tested Sandbox and it doesn't work either. We have contacted Authorize.Net support but they are quite unhelpful: 

 

Hello xxx,

Thank you for contacting Authorize.Net concerning your relay
response. I am happy to help. I am sorry this is happening. Here is
a link with some more basic information regarding the relay
response.

https://support.authorize.net/s/article/SIM-Relay-Response-Basics

I'm sorry but we provide limited support via this channel as we are
not developers or trained to review your code. I would suggest
making a post to the Developer Forum. We have hundreds of
developers onsite, including our Developer Evangelist, available
that can help review and provide some guidance.

https://community.developer.authorize.net

Also I want to make sure you know we have some recent updates to
the "Download to file" option for transaction reports. You can now
download directly to and Excel file. Here is a link with some more
information on those steps.

https://support.authorize.net/s/article/How-do-I-download-transaction-search-results

We look forward to your reply to further assist you. If the
information provided above satisfies your needs, please close this
Support Case. Otherwise, please add an update to this Support Case
with your follow-up questions so I can further assist you. For you
convenience the Authorize.Net Knowledge Base, located at:
https://support.authorize.net, available 24x7. For more informatio
regarding our privacy practices, visit the privacy page at
Authorize.Net.

Regards, xxx Client Support

Hope someone here can assist? Below is the form we are using against Sandbox:

 

<form action="https://test.authorize.net/gateway/transact.dll" method="POST">
    <input type="hidden" name="x_version" value="3.1">
    <input type="hidden" name="x_type" value="auth_capture">
	<input type="hidden" name="x_relay_response" value="TRUE">
	<input type="hidden" name="x_relay_url" value="https://b359c896.ngrok.io/bdpaygate/callback.php?p=authnet">
	<input type="hidden" name="x_login" value="9GYn58Ea3cUQ">
	<input type="hidden" name="x_fp_sequence" value="724">
	<input type="hidden" name="x_fp_timestamp" value="1551691378">
	<input type="hidden" name="x_show_form" value="PAYMENT_FORM">
	<input type="hidden" name="x_amount" value="5.00">
	<input type="hidden" name="x_currency_code" value="USD">
	<input type="hidden" name="x_custom" value="user_upgrade|1|b4afa|1">
	<input type="hidden" name="x_description" value="Account Upgrade: Xxx (admin)">
	<input type="hidden" name="x_fp_hash" value="4FCE0DF165F96DAA7ED71FB1D2633DE0B452A46DC94A9C8F2E75469B52ED4BFA22307E5526663D1E068150D63163FE7D925FC8EA5151D03AAC5520666D9B9363">
	
	<input type="submit" value="Pay with Authorize.Net" class="button">
</form>

Accepted Solutions
Solution
Accepted by topic author daohoangson2017
‎03-07-2019 11:48 PM
Posts: 2,765
Topics: 57
Kudos: 245
Blog Posts: 67
Registered: ‎12-05-2011

Re: Relay Response no longer working

Hello @daohoangson2017 

 

I suggest removing the query string from your relay response URL as suggested by this support article.

 

Richard

View solution in original post


All Replies
Member
Posts: 8
Registered: ‎09-21-2010

Re: Relay Response no longer working

What I've noticed is if you have more than 1 Relay URL it doesn't work.  I also noticed in January when we updated our development account to use the Signature Key for hash.  Now I have a new customer coming online and we can't get Relay working.

 

Very frustrating.

Member
Posts: 1
Registered: ‎03-05-2019

Re: Relay Response no longer working

We're experiencing the exact same behavior, nothing coming to relay response. I contacted Authorize.Net and received the same, less than helpful, response. We only have one Relay URL and the problem persists.

 

Super frustrating here too.

All Star
Posts: 661
Registered: ‎11-05-2018

Re: Relay Response no longer working

I have also recently been helping a SIM integration client who is having problems. I have tracked the issue down to the receipt page url and the relay response url being set at the same time. The bizarre thing that I’m dealing with is it is impossible to delete the receipt url. I deleted all of the other urls, but when I backspace the last remaining receipt url it comes back from the dead every time. A total mystery at this point. Only thing I can think of is this is a long distance client and the logging into the merchant interface from IP addresses half the country apart from one another has triggered some sort of security flag. The client cannot delete it either.
Solution
Accepted by topic author daohoangson2017
‎03-07-2019 11:48 PM
Posts: 2,765
Topics: 57
Kudos: 245
Blog Posts: 67
Registered: ‎12-05-2011

Re: Relay Response no longer working

Hello @daohoangson2017 

 

I suggest removing the query string from your relay response URL as suggested by this support article.

 

Richard

All Star
Posts: 661
Registered: ‎11-05-2018

Re: Relay Response no longer working

@scott_k et al,

I just finished my tangle with the relay response. In addition to what @RichardH said, I found that passing in the API call and merchant interface simultaneously does well. There is a cross reference that occurs between the two. So you cannot dynamically pass a relay response url. You have to submit the same url every time. So if you have user names or invoice numbers tied to orders, you cannot pass a url https://Mysite.com/order-confirmation/ordernumber245383/, but you can pass the same url without the ordernumber......3/.

If you want to pass a dynamic url you can do that with the receipt url. You just have a button instead of an automatic redirect. That’s what we finally determined to do. I will also say that after doing consecutive Accept Hosted integrations and then getting this first SIM project, the grass is much greener where I started. This client has decided to upgrade in the near term future and it will be worth it for all parties.
Member
Posts: 5
Registered: ‎10-31-2017

Re: Relay Response no longer working

Thank you very much @RichardH, I have removed the query string and it started working again. It's just weird... that same relay url has been used for years without issue. Anyway, time to migrate away from SIM I guess.

Member
Posts: 4
Registered: ‎03-08-2019

Re: Relay Response no longer working

Thanks everyone for your help getting this resolved!