Reply
Member
Posts: 4
Registered: ‎05-16-2019

Relay response not comming in sandbox (DirectPost)

Hi,

Authorize.net stopped to send transaction data to relay response in sandbox mode. I'm getting email notification saying: 

 

Your script timed out while we were trying to post transaction results to it.

 

The relay response URL is available publickly. Could anyone help?

Posts: 2,765
Topics: 57
Kudos: 245
Blog Posts: 67
Registered: ‎12-05-2011

Re: Relay response not comming in sandbox (DirectPost)

Hi @achaikovskyi 

 

Is it also on port 80 or 443?  You relay response cannot be on a non-standard port.

 

Richard

Member
Posts: 4
Registered: ‎05-16-2019

Re: Relay response not comming in sandbox (DirectPost)

@RichardH ,

It is on port 80. Sandbox is operating in live mode as well as x_test_request param is set to false in request.

All Star
Posts: 684
Registered: ‎11-05-2018

Re: Relay response not comming in sandbox (DirectPost)

[ Edited ]
@achaikovskyi

I am almost certain the issue has 0 to do with auth.net and is related to your script that intercepts the relay. Post your relay response script here and I will look at it when I’m killing time.
Member
Posts: 4
Registered: ‎05-16-2019

Re: Relay response not comming in sandbox (DirectPost)

@Renaissance , that is actually standard Magento 2 module (this is not a single file). As I said it was working fine yeasterday morning, but now it doesn't. There is no incoming request from Authorize.net in access.log file of the web server which means that Authorize.net either didn't send any request to relay response URL or it couldn't reach it for some reason. When I initiate POST request to the same relay url using curl or a browser I see a record of it in access log of the web server as well as payment.log of magento.

Member
Posts: 4
Registered: ‎05-16-2019

Re: Relay response not comming in sandbox (DirectPost)

@RichardH , @Renaissance, thank you for your help. I tried today to place an order again and now everything works fine. I didn't change anything in the code and settings so looks like there was an issue on Authorize.net side, or maybe there is limit of transactions per sandbox account.

All Star
Posts: 684
Registered: ‎11-05-2018

Re: Relay response not comming in sandbox (DirectPost)

@achaikovskyi 

 

You're welcome. Glad it started working. Could you kindly mark this question solved?